mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
73 lines
2.3 KiB
Diff
73 lines
2.3 KiB
Diff
From b0321721be50b80c03a51866a94fde4f94690e18 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
|
|
Date: Wed, 15 Jun 2022 21:42:59 +0200
|
|
Subject: [PATCH] mtd: allow getting MTD device associated with a specific DT
|
|
node
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
MTD subsystem API allows interacting with MTD devices (e.g. reading,
|
|
writing, handling bad blocks). So far a random driver could get MTD
|
|
device only by its name (get_mtd_device_nm()). This change allows
|
|
getting them also by a DT node.
|
|
|
|
This API is required for drivers handling DT defined MTD partitions in a
|
|
specific way (e.g. U-Boot (sub)partition with environment variables).
|
|
|
|
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
|
|
Acked-by: Miquel Raynal <miquel.raynal@bootlin.com>
|
|
Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
|
|
---
|
|
drivers/mtd/mtdcore.c | 28 ++++++++++++++++++++++++++++
|
|
include/linux/mtd/mtd.h | 1 +
|
|
2 files changed, 29 insertions(+)
|
|
|
|
--- a/drivers/mtd/mtdcore.c
|
|
+++ b/drivers/mtd/mtdcore.c
|
|
@@ -1229,6 +1229,34 @@ int __get_mtd_device(struct mtd_info *mt
|
|
EXPORT_SYMBOL_GPL(__get_mtd_device);
|
|
|
|
/**
|
|
+ * of_get_mtd_device_by_node - obtain an MTD device associated with a given node
|
|
+ *
|
|
+ * @np: device tree node
|
|
+ */
|
|
+struct mtd_info *of_get_mtd_device_by_node(struct device_node *np)
|
|
+{
|
|
+ struct mtd_info *mtd = NULL;
|
|
+ struct mtd_info *tmp;
|
|
+ int err;
|
|
+
|
|
+ mutex_lock(&mtd_table_mutex);
|
|
+
|
|
+ err = -EPROBE_DEFER;
|
|
+ mtd_for_each_device(tmp) {
|
|
+ if (mtd_get_of_node(tmp) == np) {
|
|
+ mtd = tmp;
|
|
+ err = __get_mtd_device(mtd);
|
|
+ break;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ mutex_unlock(&mtd_table_mutex);
|
|
+
|
|
+ return err ? ERR_PTR(err) : mtd;
|
|
+}
|
|
+EXPORT_SYMBOL_GPL(of_get_mtd_device_by_node);
|
|
+
|
|
+/**
|
|
* get_mtd_device_nm - obtain a validated handle for an MTD device by
|
|
* device name
|
|
* @name: MTD device name to open
|
|
--- a/include/linux/mtd/mtd.h
|
|
+++ b/include/linux/mtd/mtd.h
|
|
@@ -682,6 +682,7 @@ extern int mtd_device_unregister(struct
|
|
extern struct mtd_info *get_mtd_device(struct mtd_info *mtd, int num);
|
|
extern int __get_mtd_device(struct mtd_info *mtd);
|
|
extern void __put_mtd_device(struct mtd_info *mtd);
|
|
+extern struct mtd_info *of_get_mtd_device_by_node(struct device_node *np);
|
|
extern struct mtd_info *get_mtd_device_nm(const char *name);
|
|
extern void put_mtd_device(struct mtd_info *mtd);
|
|
|