mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 14:37:57 +00:00
74d00a8c38
* properly format/comment all patches * merge debloat patches * merge Kconfig patches * merge swconfig patches * merge hotplug patches * drop 200-fix_localversion.patch - upstream * drop 222-arm_zimage_none.patch - unused * drop 252-mv_cesa_depends.patch - no longer required * drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused * drop 661-fq_codel_keep_dropped_stats.patch - outdated * drop 702-phy_add_aneg_done_function.patch - upstream * drop 840-rtc7301.patch - unused * drop 841-rtc_pt7c4338.patch - upstream * drop 921-use_preinit_as_init.patch - unused * drop spio-gpio-old and gpio-mmc - unused Signed-off-by: John Crispin <john@phrozen.org>
60 lines
2.2 KiB
Diff
60 lines
2.2 KiB
Diff
From dd36f935973d91644449bd9749f6062a2bed821b Mon Sep 17 00:00:00 2001
|
|
From: Christian Lamparter <chunkeey@googlemail.com>
|
|
Date: Fri, 7 Jul 2017 17:26:46 +0200
|
|
Subject: misc: owl-loader for delayed Atheros ath9k fixup
|
|
|
|
Some devices (like the Cisco Meraki Z1 Cloud Managed Teleworker Gateway)
|
|
need to be able to initialize the PCIe wifi device. Normally, this is done
|
|
during the early stages of booting linux, because the necessary init code
|
|
is read from the memory mapped SPI and passed to pci_enable_ath9k_fixup.
|
|
However,this isn't possible for devices which have the init code for the
|
|
Atheros chip stored on NAND in an UBI volume. Hence, this module can be
|
|
used to initialze the chip when the user-space is ready to extract the
|
|
init code.
|
|
|
|
Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
|
|
Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
|
|
---
|
|
drivers/misc/Kconfig | 12 ++++++++++++
|
|
drivers/misc/Makefile | 1 +
|
|
2 files changed, 13 insertions(+)
|
|
|
|
diff --git a/drivers/misc/Kconfig b/drivers/misc/Kconfig
|
|
index 64971baf11fa..50d2eaa75d41 100644
|
|
--- a/drivers/misc/Kconfig
|
|
+++ b/drivers/misc/Kconfig
|
|
@@ -151,6 +151,18 @@ config SGI_IOC4
|
|
If you have an SGI Altix with an IOC4-based card say Y.
|
|
Otherwise say N.
|
|
|
|
+config OWL_LOADER
|
|
+ tristate "Owl loader for initializing Atheros PCI(e) Wifi chips"
|
|
+ depends on PCI
|
|
+ ---help---
|
|
+ This kernel module helps to initialize certain Qualcomm
|
|
+ Atheros' PCI(e) Wifi chips, which have the init data
|
|
+ (which contains the PCI device ID for example) stored
|
|
+ together with the calibration data in the file system.
|
|
+
|
|
+ This is necessary for devices like the Cisco Meraki Z1, say M.
|
|
+ Otherwise say N.
|
|
+
|
|
config TIFM_CORE
|
|
tristate "TI Flash Media interface support"
|
|
depends on PCI
|
|
diff --git a/drivers/misc/Makefile b/drivers/misc/Makefile
|
|
index 31983366090a..48c7e74a6e5a 100644
|
|
--- a/drivers/misc/Makefile
|
|
+++ b/drivers/misc/Makefile
|
|
@@ -12,6 +12,7 @@ obj-$(CONFIG_ATMEL_TCLIB) += atmel_tclib.o
|
|
obj-$(CONFIG_DUMMY_IRQ) += dummy-irq.o
|
|
obj-$(CONFIG_ICS932S401) += ics932s401.o
|
|
obj-$(CONFIG_LKDTM) += lkdtm.o
|
|
+obj-$(CONFIG_OWL_LOADER) += owl-loader.o
|
|
obj-$(CONFIG_TIFM_CORE) += tifm_core.o
|
|
obj-$(CONFIG_TIFM_7XX1) += tifm_7xx1.o
|
|
obj-$(CONFIG_PHANTOM) += phantom.o
|
|
--
|
|
2.11.0
|
|
|