openwrt/package/libs/mbedtls/patches/300-soversion-compatibility.patch
Magnus Kroken 3d771602e9 mbedtls: update to 2.16.8
This release of Mbed TLS provides bug fixes and minor enhancements. This
release includes fixes for security issues and the most notable of them
are described in more detail in the security advisories.

* Local side channel attack on RSA and static Diffie-Hellman
* Local side channel attack on classical CBC decryption in (D)TLS
* When checking X.509 CRLs, a certificate was only considered as revoked
if its revocationDate was in the past according to the local clock if
available.

Full release announcement:
https://github.com/ARMmbed/mbedtls/releases/tag/v2.16.8

Signed-off-by: Magnus Kroken <mkroken@gmail.com>
(cherry picked from commit 66893063abf56b7d8c21eceed56e5d27859eaaea)
2020-09-28 00:37:50 +02:00

35 lines
1.2 KiB
Diff

--- a/library/CMakeLists.txt
+++ b/library/CMakeLists.txt
@@ -165,7 +165,7 @@ endif(USE_STATIC_MBEDTLS_LIBRARY)
if(USE_SHARED_MBEDTLS_LIBRARY)
add_library(mbedcrypto SHARED ${src_crypto})
- set_target_properties(mbedcrypto PROPERTIES VERSION 2.16.8 SOVERSION 3)
+ set_target_properties(mbedcrypto PROPERTIES VERSION 2.16.8 SOVERSION 1)
target_link_libraries(mbedcrypto ${libs})
add_library(mbedx509 SHARED ${src_x509})
@@ -173,7 +173,7 @@ if(USE_SHARED_MBEDTLS_LIBRARY)
target_link_libraries(mbedx509 ${libs} mbedcrypto)
add_library(mbedtls SHARED ${src_tls})
- set_target_properties(mbedtls PROPERTIES VERSION 2.16.8 SOVERSION 12)
+ set_target_properties(mbedtls PROPERTIES VERSION 2.16.8 SOVERSION 10)
target_link_libraries(mbedtls ${libs} mbedx509)
install(TARGETS mbedtls mbedx509 mbedcrypto
--- a/library/Makefile
+++ b/library/Makefile
@@ -35,9 +35,9 @@ LOCAL_CFLAGS += -fPIC -fpic
endif
endif
-SOEXT_TLS=so.12
+SOEXT_TLS=so.10
SOEXT_X509=so.0
-SOEXT_CRYPTO=so.3
+SOEXT_CRYPTO=so.1
# Set AR_DASH= (empty string) to use an ar implementation that does not accept
# the - prefix for command line options (e.g. llvm-ar)