mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
88 lines
2.4 KiB
Diff
88 lines
2.4 KiB
Diff
From e94821ffebf0550b7244029b0fe360fd5627fb9b Mon Sep 17 00:00:00 2001
|
|
From: derpeter <derpeter@users.noreply.github.com>
|
|
Date: Sun, 25 Mar 2018 23:27:30 +0200
|
|
Subject: [PATCH 259/454] This commit adds support for RP3-B-Plus in in arch
|
|
arm64 (#2464)
|
|
|
|
---
|
|
arch/arm64/boot/dts/broadcom/Makefile | 1 +
|
|
arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b-plus.dts | 3 +++
|
|
arch/arm64/boot/dts/broadcom/bcm283x-rpi-lan7515.dtsi | 1 +
|
|
arch/arm64/configs/bcmrpi3_defconfig | 1 +
|
|
4 files changed, 6 insertions(+)
|
|
create mode 100644 arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b-plus.dts
|
|
create mode 120000 arch/arm64/boot/dts/broadcom/bcm283x-rpi-lan7515.dtsi
|
|
|
|
--- a/arch/arm64/boot/dts/broadcom/Makefile
|
|
+++ b/arch/arm64/boot/dts/broadcom/Makefile
|
|
@@ -8,6 +8,7 @@ endif
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2837-rpi-3-b.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2709) += bcm2710-rpi-3-b.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b.dtb
|
|
+dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b-plus.dtb
|
|
|
|
dts-dirs += ../overlays
|
|
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcm2710-rpi-3-b-plus.dts
|
|
@@ -0,0 +1,3 @@
|
|
+#define RPI364
|
|
+
|
|
+#include "../../../../arm/boot/dts/bcm2710-rpi-3-b-plus.dts"
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcm283x-rpi-lan7515.dtsi
|
|
@@ -0,0 +1,43 @@
|
|
+/ {
|
|
+ aliases {
|
|
+ ethernet0 = ðernet;
|
|
+ };
|
|
+};
|
|
+
|
|
+&usb {
|
|
+ usb1@1 {
|
|
+ compatible = "usb424,2514";
|
|
+ reg = <1>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ usb1_1@1 {
|
|
+ compatible = "usb424,2514";
|
|
+ reg = <1>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ ethernet: usbether@1 {
|
|
+ compatible = "usb424,7800";
|
|
+ reg = <1>;
|
|
+ microchip,eee-enabled;
|
|
+ microchip,tx-lpi-timer = <600>; /* non-aggressive*/
|
|
+ /*
|
|
+ * led0 = 1:link1000/activity
|
|
+ * led1 = 6:link10/100/activity
|
|
+ */
|
|
+ microchip,led-modes = <1 6>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+
|
|
+/ {
|
|
+ __overrides__ {
|
|
+ eee = <ðernet>,"microchip,eee-enabled?";
|
|
+ tx_lpi_timer = <ðernet>,"microchip,tx-lpi-timer:0";
|
|
+ eth_led0 = <ðernet>,"microchip,led-modes:0";
|
|
+ eth_led1 = <ðernet>,"microchip,led-modes:4";
|
|
+ };
|
|
+};
|
|
--- a/arch/arm64/configs/bcmrpi3_defconfig
|
|
+++ b/arch/arm64/configs/bcmrpi3_defconfig
|
|
@@ -479,6 +479,7 @@ CONFIG_USB_NET_SR9700=m
|
|
CONFIG_USB_NET_SR9800=m
|
|
CONFIG_USB_NET_SMSC75XX=m
|
|
CONFIG_USB_NET_SMSC95XX=y
|
|
+CONFIG_USB_LAN78XX=y
|
|
CONFIG_USB_NET_GL620A=m
|
|
CONFIG_USB_NET_NET1080=m
|
|
CONFIG_USB_NET_PLUSB=m
|