mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
105 lines
3.5 KiB
Diff
105 lines
3.5 KiB
Diff
From e8a650fc27bf1e7d858c997fddd9944e6c222260 Mon Sep 17 00:00:00 2001
|
|
From: Aaron Shaw <shawaj@gmail.com>
|
|
Date: Thu, 4 Jan 2018 15:02:16 +0000
|
|
Subject: [PATCH 157/454] add gpio-key overlay (#2329)
|
|
|
|
An overlay that allows a Linux key to be bound to a GPIO.
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 21 ++++++++
|
|
.../boot/dts/overlays/gpio-key-overlay.dts | 48 +++++++++++++++++++
|
|
3 files changed, 70 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/gpio-key-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -31,6 +31,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
googlevoicehat-soundcard.dtbo \
|
|
gpio-ir.dtbo \
|
|
gpio-ir-tx.dtbo \
|
|
+ gpio-key.dtbo \
|
|
gpio-poweroff.dtbo \
|
|
gpio-shutdown.dtbo \
|
|
hifiberry-amp.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -515,6 +515,27 @@ Params: gpio_pin Output G
|
|
Default is "0" (active-high).
|
|
|
|
|
|
+Name: gpio-key
|
|
+Info: This is a generic overlay for activating GPIO keypresses using
|
|
+ the gpio-keys library and this dtoverlay. Multiple keys can be
|
|
+ set up using multiple calls to the overlay for configuring
|
|
+ additional buttons or joysticks. You can see available keycodes
|
|
+ at https://github.com/torvalds/linux/blob/v4.12/include/uapi/
|
|
+ linux/input-event-codes.h#L64
|
|
+Load: dtoverlay=gpio-key,<param>=<val>
|
|
+Params: gpio GPIO pin to trigger on (default 3)
|
|
+ active_low When this is 1 (active low), a falling
|
|
+ edge generates a key down event and a
|
|
+ rising edge generates a key up event.
|
|
+ When this is 0 (active high), this is
|
|
+ reversed. The default is 1 (active low)
|
|
+ gpio_pull Desired pull-up/down state (off, down, up)
|
|
+ Default is "up". Note that the default pin
|
|
+ (GPIO3) has an external pullup
|
|
+ label Set a label for the key
|
|
+ keycode Set the key code for the button
|
|
+
|
|
+
|
|
Name: gpio-poweroff
|
|
Info: Drives a GPIO high or low on poweroff (including halt). Enabling this
|
|
overlay will prevent the ability to boot by driving GPIO3 low.
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/gpio-key-overlay.dts
|
|
@@ -0,0 +1,48 @@
|
|
+// Definitions for gpio-key module
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ // Configure the gpio pin controller
|
|
+ target = <&gpio>;
|
|
+ __overlay__ {
|
|
+ pin_state: button_pins@0 {
|
|
+ brcm,pins = <3>; // gpio number
|
|
+ brcm,function = <0>; // 0 = input, 1 = output
|
|
+ brcm,pull = <2>; // 0 = none, 1 = pull down, 2 = pull up
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ fragment@1 {
|
|
+ target-path = "/";
|
|
+ __overlay__ {
|
|
+ button: button@0 {
|
|
+ compatible = "gpio-keys";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pin_state>;
|
|
+ status = "okay";
|
|
+
|
|
+ key: key {
|
|
+ linux,code = <116>;
|
|
+ gpios = <&gpio 3 1>;
|
|
+ label = "KEY_POWER";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ __overrides__ {
|
|
+ gpio = <&key>,"gpios:4",
|
|
+ <&button>,"reg:0",
|
|
+ <&pin_state>,"brcm,pins:0",
|
|
+ <&pin_state>,"reg:0";
|
|
+ label = <&key>,"label";
|
|
+ keycode = <&key>,"linux,code:0";
|
|
+ gpio_pull = <&pin_state>,"brcm,pull:0";
|
|
+ active_low = <&key>,"gpios:8";
|
|
+ };
|
|
+
|
|
+};
|