mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
089b4f16aa
GDB 8.3.1 brings the following fixes and enhancements over GDB 8.3: PR c++/20020 (GDB segfault on printing objects) PR gdb/24454 (nat/x86-linux-dregs.c failed assertion) PR breakpoints/24541 (Incorrect evaluation of systemtap probes due to register being signed and probe expression assuming unsigned) PR symtab/24545 (Symbol loading performance regression with cc1) PR gdb/24592 (amd64->i386 linux syscall restart problem) PR gdb/25009 (terminate called after throwing an instance of 'srchilite::ParserException') PR gdb/25010 (Calls to error () can cause SIGTTOU to send gdb to the background) PR breakpoints/25011 (Breakpoints on file reloads broken for PIE binaries) This corrective release also brings the following testsuite fixes and enhancements: PR testsuite/25005 (gdb-caching-proc.exp takes a lot of time on skip_opencl_tests) PR testsuite/25016 (Test-case failures for -pie) GDB 8.3 includes the following changes and enhancements: * Support for new native configurations (also available as a target configuration): - RISC-V GNU/Linux (riscv*-*-linux*) - RISC-V FreeBSD (riscv*-*-freebsd*) * Support for new target configurations: - CSKY ELF (csky*-*-elf) - CSKY GNU/Linux (csky*-*-linux) - NXP S12Z ELF (s12z-*-elf) - OpenRISC GNU/Linux (or1k*-*-linux*) * Native Windows debugging is only supported on Windows XP or later. * The Python API in GDB now requires Python 2.6 or later. * GDB now supports terminal styling for the CLI and TUI. Source highlighting is also supported by building GDB with GNU Highlight. * Experimental support for compilation and injection of C++ source code into the inferior (requires GCC 7.1 or higher, built with libcp1.so). * GDB and GDBserver now support IPv6 connections. * Target description support on RISC-V targets. * Various enhancements to several commands: - "frame", "select-frame" and "info frame" commands - "info functions", "info types", "info variables" - "info thread" - "info proc" - System call alias catchpoint support on FreeBSD - "target remote" support for Unix Domain sockets. * Support for displaying all files opened by a process * DWARF index cache: GDB can now automatically save indices of DWARF symbols on disk to speed up further loading of the same binaries. * Various GDB/MI enhancements. * GDBserver on PowerPC GNU/Linux now supports access to the PPR, DSCR, TAR, EBB/PMU, and HTM registers. * Ada task switching support when debugging programs built with the Ravenscar profile added to aarch64-elf. * GDB in batch mode now exits with status 1 if the last executed command failed. * Support for building GDB with GCC's Undefined Behavior Sanitizer. Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
77 lines
2.7 KiB
Diff
77 lines
2.7 KiB
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1283,13 +1283,13 @@ if test -z "$LD"; then
|
|
fi
|
|
fi
|
|
|
|
-# Check whether -static-libstdc++ -static-libgcc is supported.
|
|
+# Check whether -static-libstdc++ is supported.
|
|
have_static_libs=no
|
|
if test "$GCC" = yes; then
|
|
saved_LDFLAGS="$LDFLAGS"
|
|
|
|
- LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
|
|
- AC_MSG_CHECKING([whether g++ accepts -static-libstdc++ -static-libgcc])
|
|
+ LDFLAGS="$LDFLAGS -static-libstdc++"
|
|
+ AC_MSG_CHECKING([whether g++ accepts -static-libstdc++])
|
|
AC_LANG_PUSH(C++)
|
|
AC_LINK_IFELSE([AC_LANG_SOURCE([
|
|
#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
|
|
@@ -1629,7 +1629,7 @@ AC_ARG_WITH(stage1-ldflags,
|
|
# trust that they are doing what they want.
|
|
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
|
|
-a "$have_static_libs" = yes; then
|
|
- stage1_ldflags="-static-libstdc++ -static-libgcc"
|
|
+ stage1_ldflags="-static-libstdc++"
|
|
fi])
|
|
AC_SUBST(stage1_ldflags)
|
|
|
|
@@ -1658,7 +1658,7 @@ AC_ARG_WITH(boot-ldflags,
|
|
# statically. But if the user explicitly specified the libraries to
|
|
# use, trust that they are doing what they want.
|
|
if test "$poststage1_libs" = ""; then
|
|
- poststage1_ldflags="-static-libstdc++ -static-libgcc"
|
|
+ poststage1_ldflags="-static-libstdc++"
|
|
fi])
|
|
AC_SUBST(poststage1_ldflags)
|
|
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -5053,14 +5053,14 @@ if test -z "$LD"; then
|
|
fi
|
|
fi
|
|
|
|
-# Check whether -static-libstdc++ -static-libgcc is supported.
|
|
+# Check whether -static-libstdc++ is supported.
|
|
have_static_libs=no
|
|
if test "$GCC" = yes; then
|
|
saved_LDFLAGS="$LDFLAGS"
|
|
|
|
- LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether g++ accepts -static-libstdc++ -static-libgcc" >&5
|
|
-$as_echo_n "checking whether g++ accepts -static-libstdc++ -static-libgcc... " >&6; }
|
|
+ LDFLAGS="$LDFLAGS -static-libstdc++"
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether g++ accepts -static-libstdc++" >&5
|
|
+$as_echo_n "checking whether g++ accepts -static-libstdc++... " >&6; }
|
|
ac_ext=cpp
|
|
ac_cpp='$CXXCPP $CPPFLAGS'
|
|
ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
|
@@ -5861,7 +5861,7 @@ else
|
|
# trust that they are doing what they want.
|
|
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
|
|
-a "$have_static_libs" = yes; then
|
|
- stage1_ldflags="-static-libstdc++ -static-libgcc"
|
|
+ stage1_ldflags="-static-libstdc++"
|
|
fi
|
|
fi
|
|
|
|
@@ -5897,7 +5897,7 @@ else
|
|
# statically. But if the user explicitly specified the libraries to
|
|
# use, trust that they are doing what they want.
|
|
if test "$poststage1_libs" = ""; then
|
|
- poststage1_ldflags="-static-libstdc++ -static-libgcc"
|
|
+ poststage1_ldflags="-static-libstdc++"
|
|
fi
|
|
fi
|
|
|