openwrt/tools/cmake/patches/160-disable_xcode_generator.patch
Hannu Nyman c456c5592e tools/cmake: Update to 3.30.2
Update cmake to version 3.30.2
Release notes: https://cmake.org/cmake/help/v3.30/release/3.30.html

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Link: https://github.com/openwrt/openwrt/pull/16059
Signed-off-by: Robert Marko <robimarko@gmail.com>
2024-08-13 11:11:36 +02:00

23 lines
471 B
Diff

--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -858,7 +858,7 @@ if(CMake_USE_XCOFF_PARSER)
endif()
# Xcode only works on Apple
-if(APPLE)
+if(APPLE_DISABLED)
target_sources(
CMakeLib
PRIVATE
--- a/Source/cmake.cxx
+++ b/Source/cmake.cxx
@@ -134,7 +134,7 @@
# include "cmGlobalGhsMultiGenerator.h"
#endif
-#if defined(__APPLE__)
+#if defined(__APPLE_DISABLED__)
# if !defined(CMAKE_BOOTSTRAP)
# include "cmGlobalXCodeGenerator.h"