mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
09f8f21ae3
Using the local gnulib source during bootstrap allows for fine-grained control over the macros and source files for use with coreutils but part of gnulib instead of coreutils, without having to wait for a release or deal with gnulib as a git submodule. In this case, the execution of autotools must be skipped by force. Autoconf and Automake during bootstrap on coreutils only works right when using directly checked-out source. There is a symbol in gnulib, @GNULIB_TIME@ that is not yet defined in coreutils source, so we use the backup of lib/time.in.h instead of the one provided by gnulib source. Signed-off-by: Michael Pratt <mcpratt@pm.me>
46 lines
1.2 KiB
Diff
46 lines
1.2 KiB
Diff
--- a/bootstrap
|
|
+++ b/bootstrap
|
|
@@ -278,7 +278,7 @@ check_exists() {
|
|
($2 --version </dev/null)
|
|
fi
|
|
else
|
|
- ($1 --version </dev/null) >/dev/null 2>&1
|
|
+ ($@ --version </dev/null) >/dev/null 2>&1
|
|
fi
|
|
|
|
test $? -lt 126
|
|
@@ -563,7 +563,7 @@ p
|
|
q'
|
|
|
|
get_version() {
|
|
- app=$1
|
|
+ app="$@"
|
|
|
|
$app --version >/dev/null 2>&1 || { $app --version; return 1; }
|
|
|
|
@@ -620,13 +620,13 @@ check_versions() {
|
|
if [ "$req_ver" = "-" ]; then
|
|
# Merely require app to exist; not all prereq apps are well-behaved
|
|
# so we have to rely on $? rather than get_version.
|
|
- if ! check_exists --verbose $app; then
|
|
+ if ! check_exists --verbose "$app"; then
|
|
warn_ "Error: '$app' not found"
|
|
ret=1
|
|
fi
|
|
else
|
|
# Require app to produce a new enough version string.
|
|
- inst_ver=$(get_version $app)
|
|
+ inst_ver=$(get_version "$app")
|
|
if [ ! "$inst_ver" ]; then
|
|
warn_ "Error: '$app' not found"
|
|
ret=1
|
|
@@ -923,7 +923,7 @@ version_controlled_file() {
|
|
# two just-pre-run programs.
|
|
|
|
# Import from gettext.
|
|
-with_gettext=yes
|
|
+with_gettext=no
|
|
grep '^[ ]*AM_GNU_GETTEXT_VERSION(' configure.ac >/dev/null || \
|
|
with_gettext=no
|
|
|