mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
0a827ebd2f
This patch is to upgrade kernel to 4.14 for layerscape. patches-4.14 for layerscape included two categories. - NXP Layerscape SDK kernel-4.14 patches All patches on tag LSDK-18.09-V4.14 were ported to OpenWrt kernel. Since there were hundreds patches, we had to make an all-in-one patch for each IP/feature. See below links for LSDK kernel. https://lsdk.github.io/components.html https://source.codeaurora.org/external/qoriq/qoriq-components/linux - Non-LSDK kernel patches Other patches which were not in LSDK were just put in patches-4.14. Kept below patches from patches-4.9. 303-dts-layerscape-add-traverse-ls1043.patch 821-add-esdhc-vsel-to-ls1043.patch 822-rgmii-fixed-link.patch Renamed and rebase them as below in patches-4.14, 303-add-DTS-for-Traverse-LS1043-Boards.patch 712-sdk-dpaa-rgmii-fixed-link.patch 824-mmc-sdhci-of-esdhc-add-voltage-switch-support-for-ls.patch Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com> Signed-off-by: Biwen Li <biwen.li@nxp.com>
97 lines
2.5 KiB
Diff
97 lines
2.5 KiB
Diff
From 263092cd68368ac6f030b847a1d5b0069bc2cef3 Mon Sep 17 00:00:00 2001
|
|
From: Mathew McBride <matt@traverse.com.au>
|
|
Date: Tue, 17 Apr 2018 10:01:03 +1000
|
|
Subject: [PATCH 05/40] add DTS for Traverse LS1043 Boards
|
|
|
|
Signed-off-by: Mathew McBride <matt@traverse.com.au>
|
|
---
|
|
arch/arm64/boot/dts/freescale/Makefile | 5 +++-
|
|
.../boot/dts/freescale/traverse-ls1043s.dts | 29 +++++++++++++++++++
|
|
.../boot/dts/freescale/traverse-ls1043v.dts | 29 +++++++++++++++++++
|
|
3 files changed, 62 insertions(+), 1 deletion(-)
|
|
|
|
--- a/arch/arm64/boot/dts/freescale/Makefile
|
|
+++ b/arch/arm64/boot/dts/freescale/Makefile
|
|
@@ -22,7 +22,10 @@ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls2
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls2080a-simu.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls2088a-qds.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls2088a-rdb.dtb
|
|
-
|
|
+
|
|
+dtb-$(CONFIG_ARCH_LAYERSCAPE) += traverse-ls1043v.dtb
|
|
+dtb-$(CONFIG_ARCH_LAYERSCAPE) += traverse-ls1043s.dtb
|
|
+
|
|
always := $(dtb-y)
|
|
subdir-y := $(dts-dirs)
|
|
clean-files := *.dtb
|
|
--- a/arch/arm64/boot/dts/freescale/traverse-ls1043s.dts
|
|
+++ b/arch/arm64/boot/dts/freescale/traverse-ls1043s.dts
|
|
@@ -330,3 +330,32 @@
|
|
&sata {
|
|
status = "disabled";
|
|
};
|
|
+
|
|
+/* Additions for Layerscape SDK (4.4/4.9) Kernel only
|
|
+ * These kernels need additional setup for FMan/QMan DMA shared memory
|
|
+ */
|
|
+
|
|
+#include "qoriq-qman-portals-sdk.dtsi"
|
|
+#include "qoriq-bman-portals-sdk.dtsi"
|
|
+
|
|
+&bman_fbpr {
|
|
+ compatible = "fsl,bman-fbpr";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+&qman_fqd {
|
|
+ compatible = "fsl,qman-fqd";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+&qman_pfdr {
|
|
+ compatible = "fsl,qman-pfdr";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+
|
|
+&soc {
|
|
+#include "qoriq-dpaa-eth.dtsi"
|
|
+#include "qoriq-fman3-0-6oh.dtsi"
|
|
+};
|
|
+
|
|
+&fman0 {
|
|
+ compatible = "fsl,fman", "simple-bus";
|
|
+};
|
|
--- a/arch/arm64/boot/dts/freescale/traverse-ls1043v.dts
|
|
+++ b/arch/arm64/boot/dts/freescale/traverse-ls1043v.dts
|
|
@@ -251,3 +251,32 @@
|
|
&sata {
|
|
status = "disabled";
|
|
};
|
|
+
|
|
+/* Additions for Layerscape SDK (4.4/4.9) Kernel only
|
|
+ * These kernels need additional setup for FMan/QMan DMA shared memory
|
|
+ */
|
|
+
|
|
+#include "qoriq-qman-portals-sdk.dtsi"
|
|
+#include "qoriq-bman-portals-sdk.dtsi"
|
|
+
|
|
+&bman_fbpr {
|
|
+ compatible = "fsl,bman-fbpr";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+&qman_fqd {
|
|
+ compatible = "fsl,qman-fqd";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+&qman_pfdr {
|
|
+ compatible = "fsl,qman-pfdr";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+
|
|
+&soc {
|
|
+#include "qoriq-dpaa-eth.dtsi"
|
|
+#include "qoriq-fman3-0-6oh.dtsi"
|
|
+};
|
|
+
|
|
+&fman0 {
|
|
+ compatible = "fsl,fman", "simple-bus";
|
|
+};
|