mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 07:22:33 +00:00
99c9d8abd6
Changelog: https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.15.148 Removed upstreamed: generic/hack-5.15/321-powerpc_crtsavres_prereq.patch[1] Manually rebased: target/linux/octeontx/patches-5.15/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch[2] All other patches automatically rebased. 1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.148&id=0b11a145eb00d51f7ef18cfcae587b93f9adb1e9 2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit?h=v5.15.148&id=b67064bd372300a75293efbbc70624996dccffd4 Build system: x86_64 Build-tested: ramips/tplink_archer-a6-v3 Run-tested: ramips/tplink_archer-a6-v3 Signed-off-by: John Audia <therealgraysky@proton.me>
35 lines
1.1 KiB
Diff
35 lines
1.1 KiB
Diff
---
|
|
drivers/leds/Kconfig | 10 ++++++++++
|
|
drivers/leds/Makefile | 1 +
|
|
2 files changed, 11 insertions(+)
|
|
|
|
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -878,6 +878,16 @@ source "drivers/leds/blink/Kconfig"
|
|
comment "Flash and Torch LED drivers"
|
|
source "drivers/leds/flash/Kconfig"
|
|
|
|
+config LEDS_SMARTRG_LED
|
|
+ tristate "LED support for Adtran SmartRG"
|
|
+ depends on LEDS_CLASS && I2C && OF
|
|
+ help
|
|
+ This option enables support for the Adtran SmartRG platform
|
|
+ system LED driver.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the module
|
|
+ will be called leds-smartrg-system.
|
|
+
|
|
comment "LED Triggers"
|
|
source "drivers/leds/trigger/Kconfig"
|
|
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -77,6 +77,7 @@ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
|
obj-$(CONFIG_LEDS_REGULATOR) += leds-regulator.o
|
|
obj-$(CONFIG_LEDS_S3C24XX) += leds-s3c24xx.o
|
|
obj-$(CONFIG_LEDS_SC27XX_BLTC) += leds-sc27xx-bltc.o
|
|
+obj-$(CONFIG_LEDS_SMARTRG_LED) += leds-smartrg-system.o
|
|
obj-$(CONFIG_LEDS_SUNFIRE) += leds-sunfire.o
|
|
obj-$(CONFIG_LEDS_SYSCON) += leds-syscon.o
|
|
obj-$(CONFIG_LEDS_TCA6507) += leds-tca6507.o
|