mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
353 lines
8.3 KiB
Diff
353 lines
8.3 KiB
Diff
From 0222de711db11507773604084e20ad6d6960d30b Mon Sep 17 00:00:00 2001
|
|
From: wavelet2 <a3d35232@btinternet.com>
|
|
Date: Mon, 26 Mar 2018 21:05:10 +0100
|
|
Subject: [PATCH 264/454] Add overlay for JEDEC SPI NOR flash
|
|
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 9 +
|
|
.../dts/overlays/jedec-spi-nor-overlay.dts | 309 ++++++++++++++++++
|
|
3 files changed, 319 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/jedec-spi-nor-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -55,6 +55,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
iqaudio-dac.dtbo \
|
|
iqaudio-dacplus.dtbo \
|
|
iqaudio-digi-wm8804-audio.dtbo \
|
|
+ jedec-spi-nor.dtbo \
|
|
justboom-dac.dtbo \
|
|
justboom-digi.dtbo \
|
|
lirc-rpi.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -939,6 +939,15 @@ Params: card_name Override
|
|
dai stream name.
|
|
|
|
|
|
+Name: jedec-spi-nor
|
|
+Info: Adds support for JEDEC-compliant SPI NOR flash devices. (Note: The
|
|
+ "jedec,spi-nor" kernel driver was formerly known as "m25p80".)
|
|
+Load: dtoverlay=jedec-spi-nor,<param>=<val>
|
|
+Params: flash-spi<n>-<m> Enables flash device on SPI<n>, CS#<m>.
|
|
+ flash-fastr-spi<n>-<m> Enables flash device with fast read capability
|
|
+ on SPI<n>, CS#<m>.
|
|
+
|
|
+
|
|
Name: justboom-dac
|
|
Info: Configures the JustBoom DAC HAT, Amp HAT, DAC Zero and Amp Zero audio
|
|
cards
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/jedec-spi-nor-overlay.dts
|
|
@@ -0,0 +1,309 @@
|
|
+// Overlay for JEDEC SPI-NOR Flash Devices (aka m25p80)
|
|
+
|
|
+// dtparams:
|
|
+// flash-spi<n>-<m> - Enables flash device on SPI<n>, CS#<m>.
|
|
+// flash-fastr-spi<n>-<m> - Enables flash device with fast read capability on SPI<n>, CS#<m>.
|
|
+//
|
|
+// If devices are present on SPI1 or SPI2, those interfaces must be enabled with one of the spi1-1/2/3cs and/or spi2-1/2/3cs overlays.
|
|
+//
|
|
+// Example: A single flash device with fast read capability on SPI0, CS#0:
|
|
+// dtoverlay=jedec-spi-nor:flash-fastr-spi0-0
|
|
+
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2835", "brcm,bcm2708", "brcm,bcm2709";
|
|
+
|
|
+ // disable spi-dev on spi0.0
|
|
+ fragment@0 {
|
|
+ target = <&spidev0>;
|
|
+ __dormant__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // disable spi-dev on spi0.1
|
|
+ fragment@1 {
|
|
+ target = <&spidev1>;
|
|
+ __dormant__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // disable spi-dev on spi1.0
|
|
+ fragment@2 {
|
|
+ target-path = "spi1/spidev@0";
|
|
+ __dormant__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // disable spi-dev on spi1.1
|
|
+ fragment@3 {
|
|
+ target-path = "spi1/spidev@1";
|
|
+ __dormant__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // disable spi-dev on spi1.2
|
|
+ fragment@4 {
|
|
+ target-path = "spi1/spidev@2";
|
|
+ __dormant__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // disable spi-dev on spi2.0
|
|
+ fragment@5 {
|
|
+ target-path = "spi2/spidev@0";
|
|
+ __dormant__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // disable spi-dev on spi2.1
|
|
+ fragment@6 {
|
|
+ target-path = "spi2/spidev@1";
|
|
+ __dormant__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // disable spi-dev on spi2.2
|
|
+ fragment@7 {
|
|
+ target-path = "spi2/spidev@2";
|
|
+ __dormant__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // enable flash on spi0.0
|
|
+ fragment@8 {
|
|
+ target = <&spi0>;
|
|
+ __dormant__ {
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi_nor_00: spi_nor@0 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ compatible = "jedec,spi-nor";
|
|
+ reg = <0>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // enable flash on spi0.1
|
|
+ fragment@9 {
|
|
+ target = <&spi0>;
|
|
+ __dormant__ {
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi_nor_01: spi_nor@1 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ compatible = "jedec,spi-nor";
|
|
+ reg = <1>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // enable flash on spi1.0
|
|
+ fragment@10 {
|
|
+ target = <&spi1>;
|
|
+ __dormant__ {
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi_nor_10: spi_nor@0 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ compatible = "jedec,spi-nor";
|
|
+ reg = <0>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // enable flash on spi1.1
|
|
+ fragment@11 {
|
|
+ target = <&spi1>;
|
|
+ __dormant__ {
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi_nor_11: spi_nor@1 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ compatible = "jedec,spi-nor";
|
|
+ reg = <1>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // enable flash on spi1.2
|
|
+ fragment@12 {
|
|
+ target = <&spi1>;
|
|
+ __dormant__ {
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi_nor_12: spi_nor@2 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ compatible = "jedec,spi-nor";
|
|
+ reg = <2>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // enable flash on spi2.0
|
|
+ fragment@13 {
|
|
+ target = <&spi2>;
|
|
+ __dormant__ {
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi_nor_20: spi_nor@0 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ compatible = "jedec,spi-nor";
|
|
+ reg = <0>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // enable flash on spi2.1
|
|
+ fragment@14 {
|
|
+ target = <&spi2>;
|
|
+ __dormant__ {
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi_nor_21: spi_nor@1 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ compatible = "jedec,spi-nor";
|
|
+ reg = <1>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // enable flash on spi2.2
|
|
+ fragment@15 {
|
|
+ target = <&spi2>;
|
|
+ __dormant__ {
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi_nor_22: spi_nor@2 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ compatible = "jedec,spi-nor";
|
|
+ reg = <2>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // Enable fast read for device on spi0.0.
|
|
+ // Use default active low interrupt signalling.
|
|
+ fragment@16 {
|
|
+ target = <&spi_nor_00>;
|
|
+ __dormant__ {
|
|
+ m25p,fast-read;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // Enable fast read for device on spi0.1.
|
|
+ // Use default active low interrupt signalling.
|
|
+ fragment@17 {
|
|
+ target = <&spi_nor_01>;
|
|
+ __dormant__ {
|
|
+ m25p,fast-read;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // Enable fast read for device on spi1.0.
|
|
+ // Use default active low interrupt signalling.
|
|
+ fragment@18 {
|
|
+ target = <&spi_nor_10>;
|
|
+ __dormant__ {
|
|
+ m25p,fast-read;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // Enable fast read for device on spi1.1.
|
|
+ // Use default active low interrupt signalling.
|
|
+ fragment@19 {
|
|
+ target = <&spi_nor_11>;
|
|
+ __dormant__ {
|
|
+ m25p,fast-read;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // Enable fast read for device on spi1.2.
|
|
+ // Use default active low interrupt signalling.
|
|
+ fragment@20 {
|
|
+ target = <&spi_nor_12>;
|
|
+ __dormant__ {
|
|
+ m25p,fast-read;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // Enable fast read for device on spi2.0.
|
|
+ // Use default active low interrupt signalling.
|
|
+ fragment@21 {
|
|
+ target = <&spi_nor_20>;
|
|
+ __dormant__ {
|
|
+ m25p,fast-read;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // Enable fast read for device on spi2.1.
|
|
+ // Use default active low interrupt signalling.
|
|
+ fragment@22 {
|
|
+ target = <&spi_nor_21>;
|
|
+ __dormant__ {
|
|
+ m25p,fast-read;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // Enable fast read for device on spi2.2.
|
|
+ // Use default active low interrupt signalling.
|
|
+ fragment@23 {
|
|
+ target = <&spi_nor_22>;
|
|
+ __dormant__ {
|
|
+ m25p,fast-read;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ __overrides__ {
|
|
+ flash-spi0-0 = <0>,"+0+8";
|
|
+ flash-spi0-1 = <0>,"+1+9";
|
|
+ flash-spi1-0 = <0>,"+2+10";
|
|
+ flash-spi1-1 = <0>,"+3+11";
|
|
+ flash-spi1-2 = <0>,"+4+12";
|
|
+ flash-spi2-0 = <0>,"+5+13";
|
|
+ flash-spi2-1 = <0>,"+6+14";
|
|
+ flash-spi2-2 = <0>,"+7+15";
|
|
+ flash-fastr-spi0-0 = <0>,"+0+8+16";
|
|
+ flash-fastr-spi0-1 = <0>,"+1+9+17";
|
|
+ flash-fastr-spi1-0 = <0>,"+2+10+18";
|
|
+ flash-fastr-spi1-1 = <0>,"+3+11+19";
|
|
+ flash-fastr-spi1-2 = <0>,"+4+12+20";
|
|
+ flash-fastr-spi2-0 = <0>,"+5+13+21";
|
|
+ flash-fastr-spi2-1 = <0>,"+6+14+22";
|
|
+ flash-fastr-spi2-2 = <0>,"+7+15+23";
|
|
+ };
|
|
+};
|
|
+
|