mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
eda5930d43
Backport merged upstream patch that adds support for firmware loader
from NVMEM or attached filesystem for Aquantia PHYs.
Refresh all kernel patches affected by this change.
Also update the path for aquantia .ko that got moved to dedicated
directory upstream.
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
[rmilecki: port to 5.15]
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
(cherry picked from commit 1b3259eb5c
)
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
From 128dc09b0af36772062142ce9e85b19c84ac789a Mon Sep 17 00:00:00 2001
|
|
From: Daniel Golle <daniel@makrotopia.org>
|
|
Date: Tue, 28 Feb 2023 17:53:37 +0000
|
|
Subject: [PATCH] net: phy: add driver for MediaTek 2.5G PHY
|
|
|
|
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|
---
|
|
drivers/net/phy/Kconfig | 7 ++
|
|
drivers/net/phy/Makefile | 1 +
|
|
drivers/net/phy/mediatek-2p5ge.c | 220 +++++++++++++++++++++++++++++++
|
|
3 files changed, 226 insertions(+)
|
|
create mode 100644 drivers/net/phy/mediatek-2p5ge.c
|
|
|
|
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -302,6 +302,13 @@ config MEDIATEK_GE_SOC_PHY
|
|
present in the SoCs efuse and will dynamically calibrate VCM
|
|
(common-mode voltage) during startup.
|
|
|
|
+config MEDIATEK_2P5G_PHY
|
|
+ tristate "MediaTek 2.5G Ethernet PHY"
|
|
+ depends on (ARCH_MEDIATEK && ARM64) || COMPILE_TEST
|
|
+ default NET_MEDIATEK_SOC
|
|
+ help
|
|
+ Supports the MediaTek 2.5G Ethernet PHY.
|
|
+
|
|
config MICREL_PHY
|
|
tristate "Micrel PHYs"
|
|
help
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -76,6 +76,7 @@ obj-$(CONFIG_MARVELL_10G_PHY) += marvell
|
|
obj-$(CONFIG_MARVELL_PHY) += marvell.o
|
|
obj-$(CONFIG_MARVELL_88X2222_PHY) += marvell-88x2222.o
|
|
obj-$(CONFIG_MAXLINEAR_GPHY) += mxl-gpy.o
|
|
+obj-$(CONFIG_MEDIATEK_2P5G_PHY) += mediatek-2p5ge.o
|
|
obj-$(CONFIG_MEDIATEK_GE_PHY) += mediatek-ge.o
|
|
obj-$(CONFIG_MEDIATEK_GE_SOC_PHY) += mediatek-ge-soc.o
|
|
obj-$(CONFIG_MESON_GXL_PHY) += meson-gxl.o
|