mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 17:48:58 +00:00
0803b62fc6
Forward the OpenWrt TARGET_LDFLAGS to the linker of the fw_printenv tool.
In addition also use the more standard make invocation script.
With this change the fw_printenv tool is built with PIE and Full RELRO
support when activated globally in OpenWrt.
Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
(cherry picked from commit b7b2be0b26
)
17 lines
472 B
Diff
17 lines
472 B
Diff
--- a/tools/env/Makefile
|
|
+++ b/tools/env/Makefile
|
|
@@ -10,6 +10,13 @@
|
|
# with "CC" here for the maximum code reuse of scripts/Makefile.host.
|
|
override HOSTCC = $(CC)
|
|
|
|
+ifneq ($(TARGET_CFLAGS),)
|
|
+HOSTCFLAGS = $(TARGET_CFLAGS)
|
|
+endif
|
|
+ifneq ($(TARGET_LDFLAGS),)
|
|
+HOSTLDFLAGS = $(TARGET_LDFLAGS)
|
|
+endif
|
|
+
|
|
# Compile for a hosted environment on the target
|
|
HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
|
|
-idirafter $(srctree)/tools/env \
|