mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-19 19:27:27 +00:00
323e249ce8
This updates mac80211 to version 6.1.97-1. This code is based on Linux 6.1.97 and contains all fixes included in the upstream wireless subsystem from that kernel version. This includes many bugfixes and also some security fixes. The removed patches are already integrated in upstream Linux 6.1.97 or in backports. The following patches were integrated in upstream Linux: ath11k/0013-wifi-ath11k-synchronize-ath11k_mac_he_gi_to_nl80211_.patch ath11k/0035-wifi-ath11k-Use-platform_get_irq-to-get-the-interrup.patch ath11k/0036-wifi-ath11k-fix-SAC-bug-on-peer-addition-with-sta-ba.patch ath11k/0047-wifi-ath11k-fix-deinitialization-of-firmware-resourc.patch ath11k/0053-wifi-ath11k-fix-writing-to-unintended-memory-region.patch ath11k/0060-wifi-ath11k-Ignore-frags-from-uninitialized-peer-in-.patch ath11k/0065-wifi-ath11k-fix-tx-status-reporting-in-encap-offload.patch ath11k/0067-wifi-ath11k-Fix-SKB-corruption-in-REO-destination-ri.patch ath11k/0069-wifi-ath11k-fix-registration-of-6Ghz-only-phy-withou.patch ath11k/0080-wifi-ath11k-add-support-default-regdb-while-searchin.patch ath11k/0085-wifi-ath11k-fix-memory-leak-in-WMI-firmware-stats.patch ath11k/0086-wifi-ath11k-Add-missing-check-for-ioremap.patch ath11k/0096-wifi-ath11k-fix-boot-failure-with-one-MSI-vector.patch subsys/337-wifi-mac80211-fix-race-condition-on-enabling-fast-xm.patch The following patches were integrated in upstream backports: ath11k/901-wifi-ath11k-pci-fix-compilation-in-5.16-and-older.patch build/080-resv_start_op.patch build/110-backport_napi_build_skb.patch The following files are missing in backports, we do not have to remove them any more. Some were already missing before some were removed in this update: include/linux/cordic.h include/linux/crc8.h include/linux/eeprom_93cx6.h include/linux/wl12xx.h include/net/ieee80211.h backport-include/linux/bcm47xx_nvram.h include/linux/ath9k_platform.h include/net/bluetooth/ backports ships a dummy Mediatek wed header for older kernel versions. We backported the feature in our kernel, remove the dummy header: backport-include/linux/soc/mediatek/mtk_wed.h Remove header files for subsystems used form the mainline kernel: include/trace/events/qrtr.h include/net/rsi_91x.h backport-include/linux/platform_data/brcmnand.h Link: https://github.com/openwrt/openwrt/pull/15827 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
67 lines
2.4 KiB
Diff
67 lines
2.4 KiB
Diff
From 703d6551f71e7290619d6effe2a25a64e10538b7 Mon Sep 17 00:00:00 2001
|
|
From: Robert Marko <robimarko@gmail.com>
|
|
Date: Thu, 15 Dec 2022 12:20:52 +0100
|
|
Subject: [PATCH] ath11k: control thermal support via symbol
|
|
|
|
Currently, thermal support will get built if CONFIG_THERMAL is reachable,
|
|
however this is not suitable for OpenWrt as with ALL_KMODS being set to y
|
|
ATH11K_THERMAL wont get selected and so hwmon and thermal kmods wont get
|
|
pulled in resulting in a build-failure.
|
|
|
|
So, to avoid that, lets do what is already done for ath10k and add a
|
|
config symbol into backports for enabling thermal support.
|
|
|
|
Signed-off-by: Robert Marko <robimarko@gmail.com>
|
|
---
|
|
drivers/net/wireless/ath/ath11k/Kconfig | 7 +++++++
|
|
drivers/net/wireless/ath/ath11k/Makefile | 2 +-
|
|
drivers/net/wireless/ath/ath11k/thermal.h | 2 +-
|
|
local-symbols | 1 +
|
|
4 files changed, 10 insertions(+), 2 deletions(-)
|
|
|
|
--- a/drivers/net/wireless/ath/ath11k/Kconfig
|
|
+++ b/drivers/net/wireless/ath/ath11k/Kconfig
|
|
@@ -61,3 +61,10 @@ config ATH11K_SPECTRAL
|
|
Enable ath11k spectral scan support
|
|
|
|
Say Y to enable access to the FFT/spectral data via debugfs.
|
|
+
|
|
+config ATH11K_THERMAL
|
|
+ bool "ath11k thermal sensors and throttling support"
|
|
+ depends on ATH11K
|
|
+ depends on THERMAL
|
|
+ help
|
|
+ Enable ath11k thermal sensors and throttling support.
|
|
--- a/drivers/net/wireless/ath/ath11k/Makefile
|
|
+++ b/drivers/net/wireless/ath/ath11k/Makefile
|
|
@@ -22,7 +22,7 @@ ath11k-y += core.o \
|
|
ath11k-$(CPTCFG_ATH11K_DEBUGFS) += debugfs.o debugfs_htt_stats.o debugfs_sta.o
|
|
ath11k-$(CPTCFG_NL80211_TESTMODE) += testmode.o
|
|
ath11k-$(CPTCFG_ATH11K_TRACING) += trace.o
|
|
-ath11k-$(CONFIG_THERMAL) += thermal.o
|
|
+ath11k-$(CPTCFG_ATH11K_THERMAL) += thermal.o
|
|
ath11k-$(CPTCFG_ATH11K_SPECTRAL) += spectral.o
|
|
ath11k-$(CONFIG_PM) += wow.o
|
|
|
|
--- a/drivers/net/wireless/ath/ath11k/thermal.h
|
|
+++ b/drivers/net/wireless/ath/ath11k/thermal.h
|
|
@@ -25,7 +25,7 @@ struct ath11k_thermal {
|
|
int temperature;
|
|
};
|
|
|
|
-#if IS_REACHABLE(CONFIG_THERMAL)
|
|
+#if IS_REACHABLE(CPTCFG_ATH11K_THERMAL)
|
|
int ath11k_thermal_register(struct ath11k_base *sc);
|
|
void ath11k_thermal_unregister(struct ath11k_base *sc);
|
|
int ath11k_thermal_set_throttling(struct ath11k *ar, u32 throttle_state);
|
|
--- a/local-symbols
|
|
+++ b/local-symbols
|
|
@@ -166,6 +166,7 @@ ATH11K_DEBUG=
|
|
ATH11K_DEBUGFS=
|
|
ATH11K_TRACING=
|
|
ATH11K_SPECTRAL=
|
|
+ATH11K_THERMAL=
|
|
WLAN_VENDOR_ATMEL=
|
|
ATMEL=
|
|
PCI_ATMEL=
|