mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
4ed209326b
Siflower SF19A2890 is an SoC with: Dual-core MIPS InterAptiv at 800MHz DDR3 controller One Gigabit Ethernet MAC with RGMII and IPv4 HNAT engine Built-in 2x2 11N + 2x2 11AC WiFi radio USB 2.0 OTG I2C/SPI/GPIO and various other peripherals This PR adds support for SF19A2890 EVB with ethernet support. EVB spec: Memory: DDR3 128M Ethernet: RTL8367RB 5-port gigabit switch Flash: 16M NOR Others: MicroUSB OTG, LED x 1, Reset button x1 The built image can be flashed using u-boot recovery. This target is marked as source-only until support for a commercial router board comes. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
39 lines
1.4 KiB
Diff
39 lines
1.4 KiB
Diff
From baa6c00f7a88b28f6838a9743f66c9f7f4716e25 Mon Sep 17 00:00:00 2001
|
|
From: Chuanhong Guo <gch981213@gmail.com>
|
|
Date: Tue, 20 Aug 2024 08:34:42 +0800
|
|
Subject: [PATCH 6/9] stmmac: add support for sf19a2890
|
|
|
|
---
|
|
drivers/net/ethernet/stmicro/stmmac/Kconfig | 9 +++++++++
|
|
drivers/net/ethernet/stmicro/stmmac/Makefile | 1 +
|
|
2 files changed, 10 insertions(+)
|
|
|
|
--- a/drivers/net/ethernet/stmicro/stmmac/Kconfig
|
|
+++ b/drivers/net/ethernet/stmicro/stmmac/Kconfig
|
|
@@ -142,6 +142,15 @@ config DWMAC_ROCKCHIP
|
|
This selects the Rockchip RK3288 SoC glue layer support for
|
|
the stmmac device driver.
|
|
|
|
+config DWMAC_SF19A2890
|
|
+ tristate "Siflower SF19A2890 GMAC support"
|
|
+ default MACH_SIFLOWER_MIPS
|
|
+ help
|
|
+ Support for GMAC on Siflower SF19A2890 SoC.
|
|
+
|
|
+ This selects the Siflower SF19A2890 SoC glue layer support for
|
|
+ the stmmac device driver.
|
|
+
|
|
config DWMAC_SOCFPGA
|
|
tristate "SOCFPGA dwmac support"
|
|
default ARCH_INTEL_SOCFPGA
|
|
--- a/drivers/net/ethernet/stmicro/stmmac/Makefile
|
|
+++ b/drivers/net/ethernet/stmicro/stmmac/Makefile
|
|
@@ -21,6 +21,7 @@ obj-$(CONFIG_DWMAC_MEDIATEK) += dwmac-me
|
|
obj-$(CONFIG_DWMAC_MESON) += dwmac-meson.o dwmac-meson8b.o
|
|
obj-$(CONFIG_DWMAC_QCOM_ETHQOS) += dwmac-qcom-ethqos.o
|
|
obj-$(CONFIG_DWMAC_ROCKCHIP) += dwmac-rk.o
|
|
+obj-$(CONFIG_DWMAC_SF19A2890) += dwmac-sf19a2890.o
|
|
obj-$(CONFIG_DWMAC_SOCFPGA) += dwmac-altr-socfpga.o
|
|
obj-$(CONFIG_DWMAC_STARFIVE) += dwmac-starfive.o
|
|
obj-$(CONFIG_DWMAC_STI) += dwmac-sti.o
|