mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 15:02:32 +00:00
1c552eb44d
The MDIO bus is supported but there are errors when trying to probe and configure the external BCM5325E switch through B53 DSA. Therefore, let's add basic ethernet (but working) support for now. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
45 lines
1.6 KiB
Diff
45 lines
1.6 KiB
Diff
From 590b60fb08cb1e70fe02d3f407c6b3dbe9ad06ff Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
|
|
Date: Mon, 1 Mar 2021 07:34:39 +0100
|
|
Subject: [PATCH] net: broadcom: add BCM6348 enetsw controller driver
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This controller is present on BCM6338, BCM6348 and BCM6358 SoCs.
|
|
|
|
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|
---
|
|
drivers/net/ethernet/broadcom/Kconfig | 8 +
|
|
drivers/net/ethernet/broadcom/Makefile | 1 +
|
|
3 files changed, 1120 insertions(+)
|
|
create mode 100644 drivers/net/ethernet/broadcom/bcm6368-enetsw.c
|
|
|
|
--- a/drivers/net/ethernet/broadcom/Kconfig
|
|
+++ b/drivers/net/ethernet/broadcom/Kconfig
|
|
@@ -68,6 +68,14 @@ config BCM63XX_ENET
|
|
This driver supports the ethernet MACs in the Broadcom 63xx
|
|
MIPS chipset family (BCM63XX).
|
|
|
|
+config BCM6348_ENET
|
|
+ tristate "Broadcom BCM6348 internal mac support"
|
|
+ depends on BMIPS_GENERIC || COMPILE_TEST
|
|
+ default y
|
|
+ help
|
|
+ This driver supports Ethernet controller integrated into Broadcom
|
|
+ BCM6348 family SoCs.
|
|
+
|
|
config BCM6368_ENETSW
|
|
tristate "Broadcom BCM6368 internal mac support"
|
|
depends on BMIPS_GENERIC || COMPILE_TEST
|
|
--- a/drivers/net/ethernet/broadcom/Makefile
|
|
+++ b/drivers/net/ethernet/broadcom/Makefile
|
|
@@ -6,6 +6,7 @@
|
|
obj-$(CONFIG_B44) += b44.o
|
|
obj-$(CONFIG_BCM4908_ENET) += bcm4908_enet.o
|
|
obj-$(CONFIG_BCM63XX_ENET) += bcm63xx_enet.o
|
|
+obj-$(CONFIG_BCM6348_ENET) += bcm6348-enet.o
|
|
obj-$(CONFIG_BCM6368_ENETSW) += bcm6368-enetsw.o
|
|
obj-$(CONFIG_BCMGENET) += genet/
|
|
obj-$(CONFIG_BNX2) += bnx2.o
|