mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 06:33:41 +00:00
4d8a9a954a
Update to the latest upstream release to include recent improvements and bugfixes. Update copyright, fix typo in PKG_NAME, and remove unneeded use of MAKE_VARS definition in Makefile. Drop 001-cflags.patch and simplify 002-includes.patch after refreshing. Also simplify LTO/DCE build flags. Link: https://github.com/libbpf/bpftool/releases/tag/v7.4.0 Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
16 lines
505 B
Diff
16 lines
505 B
Diff
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -73,10 +73,10 @@ CFLAGS += -W -Wall -Wextra -Wno-unused-p
|
|
CFLAGS += $(filter-out -Wswitch-enum -Wnested-externs,$(EXTRA_WARNINGS))
|
|
CFLAGS += -DPACKAGE='"bpftool"' -D__EXPORTED_HEADERS__ \
|
|
-I$(or $(OUTPUT),.) \
|
|
- -I$(LIBBPF_INCLUDE) \
|
|
-I$(srctree)/src/kernel/bpf/ \
|
|
-I$(srctree)/include \
|
|
- -I$(srctree)/include/uapi
|
|
+ -I$(srctree)/include/uapi \
|
|
+ -I$(LIBBPF_INCLUDE)
|
|
ifneq ($(BPFTOOL_VERSION),)
|
|
CFLAGS += -DBPFTOOL_VERSION='"$(BPFTOOL_VERSION)"'
|
|
endif
|