mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
95b0c07a61
Hardware -------- CPU: Qualcomm IPQ4019 RAM: 256M FLASH: 128M NAND ETH: QCA8075 VDSL: Intel/Lantiq VRX518 PCIe attached currently not supported DECT: Dialog SC14448 currently not supported WiFi2: IPQ4019 2T2R 2SS b/g/n WiFi5: IPQ4019 2T2R 2SS n/ac LED: - Power/DSL green - WLAN green - FON/DECT green - Connect/WPS green - Info green - Info red BTN: - WLAN - FON - WPS/Connect UART: 115200n8 3.3V (located under the Dialog chip) VCC - RX - TX - GND (Square is VCC) Installation ------------ 1. Grab the uboot for the Device from the 'u-boot-fritz7530' subdirectory. Place it in the same directory as the 'eva_ramboot.py' script. It is located in the 'scripts/flashing' subdirectory of the OpenWRT tree. 2. Assign yourself the IP address 192.168.178.10/24. Connect your Computer to one of the boxes LAN ports. 3. Connect Power to the Box. As soon as the LAN port of your computer shows link, load the U-Boot to the box using following command. > ./eva_ramboot.py --offset 0x85000000 192.168.178.1 uboot-fritz7530.bin 4. The U-Boot will now start. Now assign yourself the IP address 192.168.1.70/24. Copy the OpenWRT initramfs (!) image to a TFTP server root directory and rename it to 'FRITZ7530.bin'. 5. The Box will now boot OpenWRT from RAM. This can take up to two minutes. 6. Copy the U-Boot and the OpenWRT sysupgrade (!) image to the Box using scp. SSH into the Box and first write the Bootloader to both previous kernel partitions. > mtd write /path/to/uboot-fritz7530.bin uboot0 > mtd write /path/to/uboot-fritz7530.bin uboot1 7. Remove the AVM filesystem partitions to make room for our kernel + rootfs + overlayfs. > ubirmvol /dev/ubi0 --name=avm_filesys_0 > ubirmvol /dev/ubi0 --name=avm_filesys_1 8. Flash OpenWRT peristently using sysupgrade. > sysupgrade -n /path/to/openwrt-sysupgrade.bin Signed-off-by: David Bauer <mail@david-bauer.net> [removed pcie-dts range node, refreshed on top of AP120-AC/E2600AC] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
44 lines
1.3 KiB
Diff
44 lines
1.3 KiB
Diff
From 8f68331e14dff9a101f2d0e1d6bec84a031f27ee Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Thu, 9 Mar 2017 11:03:18 +0100
|
|
Subject: [PATCH 69/69] arm: boot: add dts files
|
|
|
|
Signed-off-by: John Crispin <john@phrozen.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 8 ++++++++
|
|
1 file changed, 8 insertions(+)
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -785,11 +785,30 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
|
qcom-apq8074-dragonboard.dtb \
|
|
qcom-apq8084-ifc6540.dtb \
|
|
qcom-apq8084-mtp.dtb \
|
|
+ qcom-ipq4018-a42.dtb \
|
|
+ qcom-ipq4018-ap120c-ac.dtb \
|
|
+ qcom-ipq4018-ea6350v3.dtb \
|
|
+ qcom-ipq4018-eap1300.dtb \
|
|
+ qcom-ipq4018-ex6100v2.dtb \
|
|
+ qcom-ipq4018-ex6150v2.dtb \
|
|
+ qcom-ipq4018-fritz4040.dtb \
|
|
+ qcom-ipq4018-jalapeno.dtb \
|
|
+ qcom-ipq4018-nbg6617.dtb \
|
|
+ qcom-ipq4018-rt-ac58u.dtb \
|
|
+ qcom-ipq4018-wre6606.dtb \
|
|
qcom-ipq4019-ap.dk01.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk04.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk04.1-c3.dtb \
|
|
qcom-ipq4019-ap.dk07.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk07.1-c2.dtb \
|
|
+ qcom-ipq4019-a62.dtb \
|
|
+ qcom-ipq4019-fritzbox-7530.dtb \
|
|
+ qcom-ipq4019-map-ac2200.dtb \
|
|
+ qcom-ipq4019-qxwlan-e2600ac-c1.dtb \
|
|
+ qcom-ipq4019-qxwlan-e2600ac-c2.dtb \
|
|
+ qcom-ipq4028-wpj428.dtb \
|
|
+ qcom-ipq4029-gl-b1300.dtb \
|
|
+ qcom-ipq4029-mr33.dtb \
|
|
qcom-ipq8064-ap148.dtb \
|
|
qcom-msm8660-surf.dtb \
|
|
qcom-msm8960-cdp.dtb \
|