mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
f1f97db627
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
41 lines
1.2 KiB
Diff
41 lines
1.2 KiB
Diff
From 2b88563ee5aafd9571d965b7f2093a0f58d98a31 Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Thu, 26 Nov 2020 12:02:21 +0100
|
|
Subject: net: dsa: Add support for rtl838x switch
|
|
|
|
* rename the target to realtek
|
|
* add refactored DSA driver
|
|
* add latest gpio driver
|
|
* lots of arch cleanups
|
|
* new irq driver
|
|
* additional boards
|
|
|
|
Submitted-by: Bert Vermeulen <bert@biot.com>
|
|
Submitted-by: Birger Koblitz <mail@birger-koblitz.de>
|
|
Submitted-by: Sander Vanheule <sander@svanheule.net>
|
|
Submitted-by: Bjørn Mork <bjorn@mork.no>
|
|
Submitted-by: John Crispin <john@phrozen.org>
|
|
---
|
|
drivers/net/dsa/rtl83xx/Kconfig | 2 ++
|
|
drivers/net/dsa/rtl83xx/Makefile | 1 +
|
|
2 files changed, 3 insertions(+)
|
|
|
|
--- a/drivers/net/dsa/Kconfig
|
|
+++ b/drivers/net/dsa/Kconfig
|
|
@@ -68,6 +68,8 @@ config NET_DSA_QCA8K
|
|
This enables support for the Qualcomm Atheros QCA8K Ethernet
|
|
switch chips.
|
|
|
|
+source "drivers/net/dsa/rtl83xx/Kconfig"
|
|
+
|
|
config NET_DSA_REALTEK_SMI
|
|
tristate "Realtek SMI Ethernet switch family support"
|
|
depends on NET_DSA
|
|
--- a/drivers/net/dsa/Makefile
|
|
+++ b/drivers/net/dsa/Makefile
|
|
@@ -23,3 +23,4 @@ obj-y += mv88e6xxx/
|
|
obj-y += ocelot/
|
|
obj-y += qca/
|
|
obj-y += sja1105/
|
|
+obj-y += rtl83xx/
|