mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 01:28:59 +00:00
c37d7a7e8f
crate a relative symlink to libc.so because make wildcard function ignores broken symlinks SVN-Revision: 46123
12 lines
369 B
Diff
12 lines
369 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -180,7 +180,7 @@ $(DESTDIR)$(includedir)/%: include/%
|
|
$(INSTALL) -D -m 644 $< $@
|
|
|
|
$(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(libdir)/libc.so
|
|
- $(INSTALL) -D -l $(libdir)/libc.so $@ || true
|
|
+ $(INSTALL) -D -l libc.so $@ || true
|
|
|
|
install-libs: $(ALL_LIBS:lib/%=$(DESTDIR)$(libdir)/%) $(if $(SHARED_LIBS),$(DESTDIR)$(LDSO_PATHNAME),)
|
|
|