mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
f1f97db627
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
49 lines
1.7 KiB
Diff
49 lines
1.7 KiB
Diff
From 2b88563ee5aafd9571d965b7f2093a0f58d98a31 Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Thu, 26 Nov 2020 12:02:21 +0100
|
|
Subject: net: ethernet: Add support for RTL838x ethernet
|
|
|
|
* rename the target to realtek
|
|
* add refactored DSA driver
|
|
* add latest gpio driver
|
|
* lots of arch cleanups
|
|
* new irq driver
|
|
* additional boards
|
|
|
|
Submitted-by: Bert Vermeulen <bert@biot.com>
|
|
Submitted-by: Birger Koblitz <mail@birger-koblitz.de>
|
|
Submitted-by: Sander Vanheule <sander@svanheule.net>
|
|
Submitted-by: Bjørn Mork <bjorn@mork.no>
|
|
Submitted-by: John Crispin <john@phrozen.org>
|
|
---
|
|
drivers/net/ethernet/Kconfig | 7 +-
|
|
drivers/net/ethernet/Makefile | 1 +
|
|
2 files changed, 8 insertions(+)
|
|
|
|
--- a/drivers/net/ethernet/Kconfig
|
|
+++ b/drivers/net/ethernet/Kconfig
|
|
@@ -163,6 +163,13 @@ source "drivers/net/ethernet/rdc/Kconfig
|
|
source "drivers/net/ethernet/realtek/Kconfig"
|
|
source "drivers/net/ethernet/renesas/Kconfig"
|
|
source "drivers/net/ethernet/rocker/Kconfig"
|
|
+
|
|
+config NET_RTL838X
|
|
+ tristate "Realtek rtl838x Ethernet MAC support"
|
|
+ depends on RTL83XX
|
|
+ help
|
|
+ Say Y here if you want to use the Realtek rtl838x Gbps Ethernet MAC.
|
|
+
|
|
source "drivers/net/ethernet/samsung/Kconfig"
|
|
source "drivers/net/ethernet/seeq/Kconfig"
|
|
source "drivers/net/ethernet/sfc/Kconfig"
|
|
--- a/drivers/net/ethernet/Makefile
|
|
+++ b/drivers/net/ethernet/Makefile
|
|
@@ -75,6 +75,7 @@ obj-$(CONFIG_NET_VENDOR_REALTEK) += real
|
|
obj-$(CONFIG_NET_VENDOR_RENESAS) += renesas/
|
|
obj-$(CONFIG_NET_VENDOR_RDC) += rdc/
|
|
obj-$(CONFIG_NET_VENDOR_ROCKER) += rocker/
|
|
+obj-$(CONFIG_NET_RTL838X) += rtl838x_eth.o
|
|
obj-$(CONFIG_NET_VENDOR_SAMSUNG) += samsung/
|
|
obj-$(CONFIG_NET_VENDOR_SEEQ) += seeq/
|
|
obj-$(CONFIG_NET_VENDOR_SILAN) += silan/
|