openwrt/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
Hauke Mehrtens 4f6837180e kernel: Update to version 4.4.194
Compile and runtime tested on lantiq.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
2019-09-22 23:12:37 +02:00

22 lines
643 B
Diff

Disable MIPS VDSO until the cache issues have been sorted out.
Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/arch/mips/vdso/Makefile
+++ b/arch/mips/vdso/Makefile
@@ -30,11 +30,11 @@ aflags-vdso := $(ccflags-vdso) \
# the comments on that file.
#
ifndef CONFIG_CPU_MIPSR6
- ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
- $(warning MIPS VDSO requires binutils >= 2.25)
+# ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
+# $(warning MIPS VDSO requires binutils >= 2.25)
obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
ccflags-vdso += -DDISABLE_MIPS_VDSO
- endif
+# endif
endif
# VDSO linker flags.