mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
49 lines
1.6 KiB
Diff
49 lines
1.6 KiB
Diff
From fed7cef5e4f2df8c6a79bebf5da1fdd3783ff6f3 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Marek=20Beh=C3=BAn?= <kabel@kernel.org>
|
|
Date: Mon, 4 Jul 2022 13:36:22 +0200
|
|
Subject: [PATCH] ARM: dts: turris-omnia: enable LED controller node
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
The LED controller node is disabled because the leds-turris-omnia driver
|
|
does not support setting the LED blinking to be controlled by the MCU.
|
|
|
|
The patches for that have now been sent [1], so let's enable the node.
|
|
|
|
[1] https://lore.kernel.org/linux-leds/20220704105955.15474-1-kabel@kernel.org/T/
|
|
|
|
Signed-off-by: Marek Behún <kabel@kernel.org>
|
|
---
|
|
arch/arm/boot/dts/armada-385-turris-omnia.dts | 7 ++-----
|
|
1 file changed, 2 insertions(+), 5 deletions(-)
|
|
|
|
--- a/arch/arm/boot/dts/armada-385-turris-omnia.dts
|
|
+++ b/arch/arm/boot/dts/armada-385-turris-omnia.dts
|
|
@@ -194,15 +194,13 @@
|
|
reg = <0x2b>;
|
|
#address-cells = <1>;
|
|
#size-cells = <0>;
|
|
+ status = "okay";
|
|
|
|
/*
|
|
* LEDs are controlled by MCU (STM32F0) at
|
|
* address 0x2b.
|
|
*
|
|
- * The driver does not support HW control mode
|
|
- * for the LEDs yet. Disable the LEDs for now.
|
|
- *
|
|
- * Also LED functions are not stable yet:
|
|
+ * LED functions are not stable yet:
|
|
* - there are 3 LEDs connected via MCU to PCIe
|
|
* ports. One of these ports supports mSATA.
|
|
* There is no mSATA nor PCIe function.
|
|
@@ -213,7 +211,6 @@
|
|
* B. Again there is no such function defined.
|
|
* For now we use LED_FUNCTION_INDICATOR
|
|
*/
|
|
- status = "disabled";
|
|
|
|
multi-led@0 {
|
|
reg = <0x0>;
|