mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-04 13:04:22 +00:00
f32085fc0b
Airoha is a new ARM platform based on Cortex-A53 which has recently been merged into linux-next. Due to BootROM limitations on this platform, the Cortex-A53 can't run in Aarch64 mode and code must be compiled for 32-Bit ARM. This support is based mostly on those linux-next commits backported for kernel 5.15. Patches: 1 - platform support = linux-next 2 - clock driver = linux-next 3 - gpio driver = linux-next 4 - linux,usable-memory-range dts support = linux-next 5 - mtd spinand driver 6 - spi driver 7 - pci driver (kconfig only, uses mediatek PCI) = linux-next Still missing: - Ethernet driver - Sysupgrade support A.t.m there exists one subtarget EN7523 with only one evaluation board. The initramfs can be run with the following commands from u-boot: - u-boot> setenv bootfile \ openwrt-airoha-airoha_en7523-evb-initramfs-kernel.bin u-boot> tftpboot u-boot> bootm 0x81800000 - Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
diff --git a/drivers/clk/Kconfig b/drivers/clk/Kconfig
|
|
index c5b3dc97..c973ac1a 100644
|
|
--- a/drivers/clk/Kconfig
|
|
+++ b/drivers/clk/Kconfig
|
|
@@ -192,6 +192,15 @@ config COMMON_CLK_CS2000_CP
|
|
help
|
|
If you say yes here you get support for the CS2000 clock multiplier.
|
|
|
|
+config COMMON_CLK_EN7523
|
|
+ bool "Clock driver for Airoha EN7523 SoC system clocks"
|
|
+ depends on OF
|
|
+ depends on ARCH_AIROHA || COMPILE_TEST
|
|
+ default ARCH_AIROHA
|
|
+ help
|
|
+ This driver provides the fixed clocks and gates present on Airoha
|
|
+ ARM silicon.
|
|
+
|
|
config COMMON_CLK_FSL_FLEXSPI
|
|
tristate "Clock driver for FlexSPI on Layerscape SoCs"
|
|
depends on ARCH_LAYERSCAPE || COMPILE_TEST
|
|
diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
|
|
index e4231212..be11d88c 100644
|
|
--- a/drivers/clk/Makefile
|
|
+++ b/drivers/clk/Makefile
|
|
@@ -27,6 +27,7 @@ obj-$(CONFIG_COMMON_CLK_CDCE925) += clk-cdce925.o
|
|
obj-$(CONFIG_ARCH_CLPS711X) += clk-clps711x.o
|
|
obj-$(CONFIG_COMMON_CLK_CS2000_CP) += clk-cs2000-cp.o
|
|
obj-$(CONFIG_ARCH_SPARX5) += clk-sparx5.o
|
|
+obj-$(CONFIG_COMMON_CLK_EN7523) += clk-en7523.o
|
|
obj-$(CONFIG_COMMON_CLK_FIXED_MMIO) += clk-fixed-mmio.o
|
|
obj-$(CONFIG_COMMON_CLK_FSL_FLEXSPI) += clk-fsl-flexspi.o
|
|
obj-$(CONFIG_COMMON_CLK_FSL_SAI) += clk-fsl-sai.o
|