mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-02 20:16:59 +00:00
ee67afeda9
This refreshes the patches on top of kernel 5.4.127. Deleted (upstreamed): bcm27xx/patches-5.10/950-0005-Revert-mailbox-avoid-timer-start-from-callback.patch [0] bcm27xx/patches-5.10/950-0678-bcm2711_thermal-Don-t-clamp-temperature-at-zero.patch [1] Needed manual modifications: bcm27xx/patches-5.10/950-0410-drm-atomic-Pass-the-full-state-to-CRTC-atomic-begin-.patch [0]: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.10.127&id=bb2220e0672b7433a9a42618599cd261b2629240 [1]: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.10.127&id=83603802954068ccd1b8a3f2ccbbaf5e0862acb0 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
24 lines
767 B
Diff
24 lines
767 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -95,6 +95,10 @@ config IP17XX_PHY
|
|
tristate "Driver for IC+ IP17xx switches"
|
|
select SWCONFIG
|
|
|
|
+config MVSWITCH_PHY
|
|
+ tristate "Driver for Marvell 88E6060 switches"
|
|
+ select ETHERNET_PACKET_MANGLE
|
|
+
|
|
config PSB6970_PHY
|
|
tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
|
|
select SWCONFIG
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -29,6 +29,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
|
obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
|
|
obj-$(CONFIG_SWCONFIG_B53) += b53/
|
|
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
|
+obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
|
obj-$(CONFIG_PSB6970_PHY) += psb6970.o
|
|
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
|
obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
|