mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
9261e7447e
This makes the patches which were just copied in the previous commit apply on top of kernel 4.19. The patches in the backports-4.19 folder were checked if they are really in kernel 4.19 based on the title and only removed if they were found in the upstream kernel. The following additional patches form the pending folder went into upstream Linux 4.19: pending-4.19/171-usb-dwc2-Fix-inefficient-copy-of-unaligned-buffers.patch pending-4.19/190-2-5-e1000e-Fix-wrong-comment-related-to-link-detection.patch pending-4.19/478-mtd-spi-nor-Add-support-for-XM25QH64A-and-XM25QH128A.patch pending-4.19/479-mtd-spi-nor-add-eon-en25qh32.patch pending-4.19/950-tty-serial-exar-generalize-rs485-setup.patch pending-4.19/340-MIPS-mm-remove-mips_dma_mapping_error.patch Bigger changes were introduced to the m25p80 spi nor driver, as far as I saw it in the new code, it now has the functionality provided in this patch: pending-4.19/450-mtd-m25p80-allow-fallback-from-spi_flash_read-to-reg.patch Part of this patch went upstream independent of OpenWrt: hack-4.19/220-gc_sections.patch This patch was reworked to match the changes done upstream. The MIPS DMA API changed a lot, this patch was rewritten to match the new DMA handling: pending-4.19/341-MIPS-mm-remove-no-op-dma_map_ops-where-possible.patch I did bigger manual changes to the following patches and I am not 100% sure if they are all correct: pending-4.19/0931-w1-gpio-fix-problem-with-platfom-data-in-w1-gpio.patch pending-4.19/411-mtd-partial_eraseblock_write.patch pending-4.19/600-netfilter_conntrack_flush.patch pending-4.19/611-netfilter_match_bypass_default_table.patch pending-4.19/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch hack-4.19/211-host_tools_portability.patch hack-4.19/221-module_exports.patch hack-4.19/321-powerpc_crtsavres_prereq.patch hack-4.19/902-debloat_proc.patch This is based on patchset from Marko Ratkaj <marko.ratkaj@sartura.hr> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
72 lines
2.5 KiB
Diff
72 lines
2.5 KiB
Diff
From b3d00b452467f621317953d9e4c6f9ae8dcfd271 Mon Sep 17 00:00:00 2001
|
|
From: Imre Kaloz <kaloz@openwrt.org>
|
|
Date: Fri, 7 Jul 2017 17:06:55 +0200
|
|
Subject: use the openwrt lzma options for now
|
|
|
|
lede-commit: 548de949f392049420a6a1feeef118b30ab8ea8c
|
|
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|
---
|
|
lib/decompress.c | 1 +
|
|
scripts/Makefile.lib | 2 +-
|
|
usr/gen_initramfs_list.sh | 10 +++++-----
|
|
3 files changed, 7 insertions(+), 6 deletions(-)
|
|
|
|
--- a/lib/decompress.c
|
|
+++ b/lib/decompress.c
|
|
@@ -49,6 +49,7 @@ static const struct compress_format comp
|
|
{ {0x1f, 0x9e}, "gzip", gunzip },
|
|
{ {0x42, 0x5a}, "bzip2", bunzip2 },
|
|
{ {0x5d, 0x00}, "lzma", unlzma },
|
|
+ { {0x6d, 0x00}, "lzma-openwrt", unlzma },
|
|
{ {0xfd, 0x37}, "xz", unxz },
|
|
{ {0x89, 0x4c}, "lzo", unlzo },
|
|
{ {0x02, 0x21}, "lz4", unlz4 },
|
|
--- a/scripts/Makefile.lib
|
|
+++ b/scripts/Makefile.lib
|
|
@@ -324,7 +324,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
|
|
|
|
quiet_cmd_lzma = LZMA $@
|
|
cmd_lzma = (cat $(filter-out FORCE,$^) | \
|
|
- lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
|
+ lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
|
(rm -f $@ ; false)
|
|
|
|
quiet_cmd_lzo = LZO $@
|
|
--- a/usr/gen_initramfs_list.sh
|
|
+++ b/usr/gen_initramfs_list.sh
|
|
@@ -229,7 +229,7 @@ cpio_list=
|
|
output="/dev/stdout"
|
|
output_file=""
|
|
is_cpio_compressed=
|
|
-compr="gzip -n -9 -f"
|
|
+compr="gzip -n -9 -f -"
|
|
|
|
arg="$1"
|
|
case "$arg" in
|
|
@@ -245,13 +245,13 @@ case "$arg" in
|
|
output=${cpio_list}
|
|
echo "$output_file" | grep -q "\.gz$" \
|
|
&& [ -x "`which gzip 2> /dev/null`" ] \
|
|
- && compr="gzip -n -9 -f"
|
|
+ && compr="gzip -n -9 -f -"
|
|
echo "$output_file" | grep -q "\.bz2$" \
|
|
&& [ -x "`which bzip2 2> /dev/null`" ] \
|
|
- && compr="bzip2 -9 -f"
|
|
+ && compr="bzip2 -9 -f -"
|
|
echo "$output_file" | grep -q "\.lzma$" \
|
|
&& [ -x "`which lzma 2> /dev/null`" ] \
|
|
- && compr="lzma -9 -f"
|
|
+ && compr="lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so"
|
|
echo "$output_file" | grep -q "\.xz$" \
|
|
&& [ -x "`which xz 2> /dev/null`" ] \
|
|
&& compr="xz --check=crc32 --lzma2=dict=1MiB"
|
|
@@ -320,7 +320,7 @@ if [ ! -z ${output_file} ]; then
|
|
if [ "${is_cpio_compressed}" = "compressed" ]; then
|
|
cat ${cpio_tfile} > ${output_file}
|
|
else
|
|
- (cat ${cpio_tfile} | ${compr} - > ${output_file}) \
|
|
+ (cat ${cpio_tfile} | ${compr} > ${output_file}) \
|
|
|| (rm -f ${output_file} ; false)
|
|
fi
|
|
[ -z ${cpio_file} ] && rm ${cpio_tfile}
|