mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 14:37:57 +00:00
102cb4742c
Refresh patches on all 4.4 supported platforms. 077-0005-bgmac-stop-clearing-DMA-receive-control-register-rig.patch removed as now upstream. Compile & run tested: ar71xx - Archer C7 v2 Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
19 lines
488 B
Diff
19 lines
488 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -621,12 +621,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
|
KBUILD_CFLAGS += $(call cc-disable-warning,frame-address,)
|
|
|
|
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
|
-KBUILD_CFLAGS += -Os
|
|
+KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)
|
|
else
|
|
ifdef CONFIG_PROFILE_ALL_BRANCHES
|
|
-KBUILD_CFLAGS += -O2
|
|
+KBUILD_CFLAGS += -O2 $(EXTRA_OPTIMIZATION)
|
|
else
|
|
-KBUILD_CFLAGS += -O2
|
|
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
|
|
endif
|
|
endif
|
|
|