mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 22:47:56 +00:00
0a4b309f41
Backport initial LEDs hw control support. Currently this is limited to only rx/tx and link events for the netdev trigger but the API got accepted and the additional modes are working on and will be backported later. Refresh every patch and add the additional config flag for QCA8K new LEDs support. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
26 lines
764 B
Diff
26 lines
764 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -367,6 +367,12 @@ config ROCKCHIP_PHY
|
|
help
|
|
Currently supports the integrated Ethernet PHY.
|
|
|
|
+config RTL8367S_GSW
|
|
+ tristate "rtl8367 Gigabit Switch support for mt7622"
|
|
+ depends on NET_VENDOR_MEDIATEK
|
|
+ help
|
|
+ This driver supports rtl8367s in mt7622
|
|
+
|
|
config SMSC_PHY
|
|
tristate "SMSC PHYs"
|
|
help
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -95,6 +95,7 @@ obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
obj-$(CONFIG_RENESAS_PHY) += uPD60620.o
|
|
obj-$(CONFIG_ROCKCHIP_PHY) += rockchip.o
|
|
+obj-$(CONFIG_RTL8367S_GSW) += rtk/
|
|
obj-$(CONFIG_SMSC_PHY) += smsc.o
|
|
obj-$(CONFIG_STE10XP) += ste10Xp.o
|
|
obj-$(CONFIG_TERANETICS_PHY) += teranetics.o
|