mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 21:58:04 +00:00
f800f8d6fc
All patches automatically rebased. Build system: x86_64 Build-tested: ipq806x/R7800, x86/64 Signed-off-by: John Audia <therealgraysky@proton.me>
26 lines
763 B
Diff
26 lines
763 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -330,6 +330,12 @@ config REALTEK_PHY
|
|
help
|
|
Supports the Realtek 821x PHY.
|
|
|
|
+config REALTEK_SOC_PHY
|
|
+ tristate "Realtek SoC PHYs"
|
|
+ depends on RTL83XX
|
|
+ help
|
|
+ Supports the PHYs found in combination with Realtek Switch SoCs
|
|
+
|
|
config RENESAS_PHY
|
|
tristate "Renesas PHYs"
|
|
help
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -89,6 +89,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
|
|
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
|
|
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
+obj-$(CONFIG_REALTEK_SOC_PHY) += rtl83xx-phy.o
|
|
obj-$(CONFIG_RENESAS_PHY) += uPD60620.o
|
|
obj-$(CONFIG_ROCKCHIP_PHY) += rockchip.o
|
|
obj-$(CONFIG_SMSC_PHY) += smsc.o
|