mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-10 15:03:07 +00:00
f8a441e020
Bump 4.4 to 4.4.107 and refreshed all patches. Made the following patch for Mediatek and Oxnas compatible with kernel 4.4.107: 0072-mtd-backport-v4.7-0day-patches-from-Boris.patch Compile-tested: ar71xx Run-tested: ar71xx Signed-off-by: Etienne Haarsma <bladeoner112@gmail.com> Reviewed-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> Tested-by: Rosen Penev <rosenp@gmail.com>
29 lines
963 B
Diff
29 lines
963 B
Diff
--- a/drivers/pinctrl/Kconfig
|
|
+++ b/drivers/pinctrl/Kconfig
|
|
@@ -228,6 +228,15 @@ config PINCTRL_COH901
|
|
COH 901 335 and COH 901 571/3. They contain 3, 5 or 7
|
|
ports of 8 GPIO pins each.
|
|
|
|
+config PINCTRL_OXNAS
|
|
+ bool "OXNAS pinctrl driver"
|
|
+ depends on OF
|
|
+ depends on ARCH_OXNAS
|
|
+ select PINMUX
|
|
+ select PINCONF
|
|
+ help
|
|
+ Say Y here to enable the oxnas pinctrl driver
|
|
+
|
|
config PINCTRL_PALMAS
|
|
bool "Pinctrl driver for the PALMAS Series MFD devices"
|
|
depends on OF && MFD_PALMAS
|
|
--- a/drivers/pinctrl/Makefile
|
|
+++ b/drivers/pinctrl/Makefile
|
|
@@ -17,6 +17,7 @@ obj-$(CONFIG_PINCTRL_AMD) += pinctrl-amd
|
|
obj-$(CONFIG_PINCTRL_DIGICOLOR) += pinctrl-digicolor.o
|
|
obj-$(CONFIG_PINCTRL_FALCON) += pinctrl-falcon.o
|
|
obj-$(CONFIG_PINCTRL_MESON) += meson/
|
|
+obj-$(CONFIG_PINCTRL_OXNAS) += pinctrl-oxnas.o
|
|
obj-$(CONFIG_PINCTRL_PALMAS) += pinctrl-palmas.o
|
|
obj-$(CONFIG_PINCTRL_PISTACHIO) += pinctrl-pistachio.o
|
|
obj-$(CONFIG_PINCTRL_ROCKCHIP) += pinctrl-rockchip.o
|