mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 08:51:13 +00:00
24737d85e8
Fix: bpftools 5.11.2 does not compile on macOS, because the -m option was placed between src and dst. Corrected by moving -m 644 before src. Signed-off-by: Georgi Valkov <gvalkov@abv.bg>
12 lines
326 B
Diff
12 lines
326 B
Diff
--- a/tools/lib/bpf/Makefile
|
|
+++ b/tools/lib/bpf/Makefile
|
|
@@ -236,7 +236,7 @@ define do_install
|
|
if [ ! -d '$(DESTDIR_SQ)$2' ]; then \
|
|
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$2'; \
|
|
fi; \
|
|
- $(INSTALL) $1 $(if $3,-m $3,) '$(DESTDIR_SQ)$2'
|
|
+ $(INSTALL) $(if $3,-m $3,) $1 '$(DESTDIR_SQ)$2'
|
|
endef
|
|
|
|
install_lib: all_cmd
|