mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
f07e572f64
bcm2708: boot tested on RPi B+ v1.2 bcm2709: boot tested on RPi 3B v1.2 and RPi 4B v1.1 4G bcm2710: boot tested on RPi 3B v1.2 bcm2711: boot tested on RPi 4B v1.1 4G Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
158 lines
3.7 KiB
Diff
158 lines
3.7 KiB
Diff
From 489b7fc3df2013766f3c4d5f682dcc7992950293 Mon Sep 17 00:00:00 2001
|
|
From: Dave Stevenson <dave.stevenson@raspberrypi.com>
|
|
Date: Mon, 6 Jul 2020 17:32:21 +0100
|
|
Subject: [PATCH] dtoverlay: Add overlay for Omnivision OV9281 image
|
|
sensor
|
|
|
|
Adds an overlay for the OV9281 mono imaging sensor using 2 CSI-2
|
|
data lanes.
|
|
|
|
Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.com>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 8 ++
|
|
arch/arm/boot/dts/overlays/ov9281-overlay.dts | 110 ++++++++++++++++++
|
|
3 files changed, 119 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/ov9281-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -115,6 +115,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
mpu6050.dtbo \
|
|
mz61581.dtbo \
|
|
ov5647.dtbo \
|
|
+ ov9281.dtbo \
|
|
papirus.dtbo \
|
|
pibell.dtbo \
|
|
piglow.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -1813,6 +1813,14 @@ Load: dtoverlay=ov5647
|
|
Params: <None>
|
|
|
|
|
|
+Name: ov9281
|
|
+Info: Omnivision OV9281 camera module.
|
|
+ Uses Unicam 1, which is the standard camera connector on most Pi
|
|
+ variants.
|
|
+Load: dtoverlay=ov9281
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: papirus
|
|
Info: PaPiRus ePaper Screen by Pi Supply (both HAT and pHAT)
|
|
Load: dtoverlay=papirus,<param>=<val>
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/ov9281-overlay.dts
|
|
@@ -0,0 +1,110 @@
|
|
+// SPDX-License-Identifier: GPL-2.0-only
|
|
+// Definitions for OV9281 camera module on VC I2C bus
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+
|
|
+/{
|
|
+ compatible = "brcm,bcm2835";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&i2c_csi_dsi>;
|
|
+ __overlay__ {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ status = "okay";
|
|
+
|
|
+ ov9281: ov9281@60 {
|
|
+ compatible = "ovti,ov9281";
|
|
+ reg = <0x60>;
|
|
+ status = "okay";
|
|
+
|
|
+ clocks = <&ov9281_clk>;
|
|
+ clock-names = "xvclk";
|
|
+
|
|
+ avdd-supply = <&ov9281_avdd>;
|
|
+ dovdd-supply = <&ov9281_dovdd>;
|
|
+ dvdd-supply = <&ov9281_dvdd>;
|
|
+
|
|
+ port {
|
|
+ ov9281_0: endpoint {
|
|
+ remote-endpoint = <&csi1_ep>;
|
|
+ clock-lanes = <0>;
|
|
+ data-lanes = <1 2>;
|
|
+ clock-noncontinuous;
|
|
+ link-frequencies =
|
|
+ /bits/ 64 <456000000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&csi1>;
|
|
+ __overlay__ {
|
|
+ status = "okay";
|
|
+
|
|
+ port {
|
|
+ csi1_ep: endpoint {
|
|
+ remote-endpoint = <&ov9281_0>;
|
|
+ data-lanes = <1 2>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@2 {
|
|
+ target = <&i2c0if>;
|
|
+ __overlay__ {
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@3 {
|
|
+ target-path="/";
|
|
+ __overlay__ {
|
|
+ ov9281_avdd: fixedregulator@0 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "ov9281_avdd";
|
|
+ regulator-min-microvolt = <2800000>;
|
|
+ regulator-max-microvolt = <2800000>;
|
|
+ gpio = <&gpio 41 GPIO_ACTIVE_HIGH>;
|
|
+ enable-active-high;
|
|
+ };
|
|
+ ov9281_dovdd: fixedregulator@1 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "ov9281_dovdd";
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+ };
|
|
+ ov9281_dvdd: fixedregulator@2 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "ov9281_dvdd";
|
|
+ regulator-min-microvolt = <1200000>;
|
|
+ regulator-max-microvolt = <1200000>;
|
|
+ };
|
|
+ ov9281_clk: ov9281-clk {
|
|
+ compatible = "fixed-clock";
|
|
+ #clock-cells = <0>;
|
|
+ clock-frequency = <24000000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@4 {
|
|
+ target = <&i2c0mux>;
|
|
+ __overlay__ {
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@5 {
|
|
+ target-path="/__overrides__";
|
|
+ __overlay__ {
|
|
+ cam0-pwdn-ctrl = <&ov9281_avdd>,"gpio:0";
|
|
+ cam0-pwdn = <&ov9281_avdd>,"gpio:4";
|
|
+ };
|
|
+ };
|
|
+};
|