mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 17:01:14 +00:00
b4184c666c
This patch adds support for Linksys WHW01 v1 ("Velop") [FCC ID Q87-03331]. Specification ------------- SOC: Qualcomm IPQ4018 WiFi 1: Qualcomm QCA4019 IEEE 802.11b/g/n WiFi 2: Qualcomm QCA4019 IEEE 802.11a/n/ac Bluetooth: Qualcomm CSR8811 (A12U) Ethernet: Qualcomm QCA8072 (2-port) SPI Flash 1: Mactronix MX25L1605D (2MB) SPI Flash 2: Winbond W25M02GV (256MB) DRAM: Nanya NT5CC128M16IP-DI (256MB) LED Controller: NXP PCA963x (I2C) Buttons: Single reset button (GPIO). Notes ----- There does not appear to be a way to trigger TFTP recovery without entering U-Boot. The device must be opened to access the serial console in order to first flash OpenWrt onto a device from factory. The device has automatic recovery backed by a second set of partitions on the larger of the two SPI flash ICs. Both the primary and secondary must be flashed to prevent accidental rollback to "factory" after 3 failed boot attempts. Serial console -------------- A serial console is available on the following pins of the populated J2 connector on the device mainboard (115200 8n1). (<-- Top of PCB / Device) J2 [o o o o o o] | | | | | `-- GND | `---- TX `--------- RX Installation instructions ------------------------- 1. Setup TFTP server with server IP set to 192.168.1.236. 2. Copy compiled `...squashfs-factory.bin` to `nodes-jr.img` in tftp root. 3. Connect to console using pinout detailed in the serial console section. 4. Power on device and press enter when prompted to drop into U-Boot. 5. Flash first partition device via `run flashimg`. 6. Once complete, reset device and allow to power up completely. 7. Once comfortable with device upgrade reboot and drop back into U-Boot. 8. Flash the second partition (recovery) via `run flashimg2`. Revert to "factory" ------------------- 1. Download latest firmware update from vendor support site. 2. Copy extracted `.img` file to `nodes-jr.img` in tftp root. 3. Connect to console using pinout detailed in the serial console section. 4. Power on device and press enter when prompted to drop into U-Boot. 5. Flash first partition device via `run flashimg`. 6. Once complete, reset device and allow to power up completely. 7. Once comfortable with device upgrade reboot and drop back into U-Boot. 8. Flash the second partition (recovery) via `run flashimg2`. Link: https://github.com/openwrt/openwrt/pull/3682 Signed-off-by: Peter Adkins <peter@sunkenlab.com> (calibration from nvmem, updated to 5.10+5.15) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
91 lines
2.7 KiB
Diff
91 lines
2.7 KiB
Diff
From a10fab12a927e60b7141a602e740d70cb4d09e4a Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Thu, 9 Mar 2017 11:03:18 +0100
|
|
Subject: [PATCH] arm: boot: add dts files
|
|
|
|
Signed-off-by: John Crispin <john@phrozen.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 23 +++++++++++++++++++++++
|
|
1 file changed, 23 insertions(+)
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -903,11 +903,77 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
|
qcom-apq8074-dragonboard.dtb \
|
|
qcom-apq8084-ifc6540.dtb \
|
|
qcom-apq8084-mtp.dtb \
|
|
+ qcom-ipq4018-a42.dtb \
|
|
+ qcom-ipq4018-ap120c-ac.dtb \
|
|
+ qcom-ipq4018-dap-2610.dtb \
|
|
+ qcom-ipq4018-cs-w3-wd1200g-eup.dtb \
|
|
+ qcom-ipq4018-magic-2-wifi-next.dtb \
|
|
+ qcom-ipq4018-ea6350v3.dtb \
|
|
+ qcom-ipq4018-eap1300.dtb \
|
|
+ qcom-ipq4018-ecw5211.dtb \
|
|
+ qcom-ipq4018-emd1.dtb \
|
|
+ qcom-ipq4018-emr3500.dtb \
|
|
+ qcom-ipq4018-ens620ext.dtb \
|
|
+ qcom-ipq4018-ex6100v2.dtb \
|
|
+ qcom-ipq4018-ex6150v2.dtb \
|
|
+ qcom-ipq4018-fritzbox-4040.dtb \
|
|
+ qcom-ipq4018-gl-ap1300.dtb \
|
|
+ qcom-ipq4018-jalapeno.dtb \
|
|
+ qcom-ipq4018-meshpoint-one.dtb \
|
|
+ qcom-ipq4018-cap-ac.dtb \
|
|
+ qcom-ipq4018-hap-ac2.dtb \
|
|
+ qcom-ipq4018-sxtsq-5-ac.dtb \
|
|
+ qcom-ipq4018-nbg6617.dtb \
|
|
+ qcom-ipq4019-oap100.dtb \
|
|
+ qcom-ipq4018-pa1200.dtb \
|
|
+ qcom-ipq4018-rt-ac58u.dtb \
|
|
+ qcom-ipq4018-rutx10.dtb \
|
|
+ qcom-ipq4018-wac510.dtb \
|
|
+ qcom-ipq4018-whw01-v1.dtb \
|
|
+ qcom-ipq4018-wre6606.dtb \
|
|
+ qcom-ipq4018-wrtq-329acn.dtb \
|
|
qcom-ipq4019-ap.dk01.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk04.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk04.1-c3.dtb \
|
|
qcom-ipq4019-ap.dk07.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk07.1-c2.dtb \
|
|
+ qcom-ipq4019-a62.dtb \
|
|
+ qcom-ipq4019-cm520-79f.dtb \
|
|
+ qcom-ipq4019-e2600ac-c1.dtb \
|
|
+ qcom-ipq4019-e2600ac-c2.dtb \
|
|
+ qcom-ipq4019-ea8300.dtb \
|
|
+ qcom-ipq4019-eap2200.dtb \
|
|
+ qcom-ipq4019-fritzbox-7530.dtb \
|
|
+ qcom-ipq4019-fritzrepeater-1200.dtb \
|
|
+ qcom-ipq4019-fritzrepeater-3000.dtb \
|
|
+ qcom-ipq4019-habanero-dvk.dtb \
|
|
+ qcom-ipq4019-hap-ac3.dtb \
|
|
+ qcom-ipq4019-map-ac2200.dtb \
|
|
+ qcom-ipq4019-lhgg-60ad.dtb \
|
|
+ qcom-ipq4019-mf286d.dtb \
|
|
+ qcom-ipq4019-mr8300.dtb \
|
|
+ qcom-ipq4019-pa2200.dtb \
|
|
+ qcom-ipq4019-r619ac-64m.dtb \
|
|
+ qcom-ipq4019-r619ac-128m.dtb \
|
|
+ qcom-ipq4019-rbr50.dtb \
|
|
+ qcom-ipq4019-rbs50.dtb \
|
|
+ qcom-ipq4019-rt-ac42u.dtb \
|
|
+ qcom-ipq4019-rtl30vw.dtb \
|
|
+ qcom-ipq4019-srr60.dtb \
|
|
+ qcom-ipq4019-srs60.dtb \
|
|
+ qcom-ipq4019-u4019-32m.dtb \
|
|
+ qcom-ipq4019-wifi.dtb \
|
|
+ qcom-ipq4019-wpj419.dtb \
|
|
+ qcom-ipq4019-wtr-m2133hp.dtb \
|
|
+ qcom-ipq4019-x1pro.dtb \
|
|
+ qcom-ipq4028-wpj428.dtb \
|
|
+ qcom-ipq4029-ap-303.dtb \
|
|
+ qcom-ipq4029-ap-303h.dtb \
|
|
+ qcom-ipq4029-ap-365.dtb \
|
|
+ qcom-ipq4029-gl-b1300.dtb \
|
|
+ qcom-ipq4019-gl-b2200.dtb \
|
|
+ qcom-ipq4029-gl-s1300.dtb \
|
|
+ qcom-ipq4029-mr33.dtb \
|
|
qcom-ipq8064-ap148.dtb \
|
|
qcom-ipq8064-rb3011.dtb \
|
|
qcom-msm8660-surf.dtb \
|