mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-27 01:11:14 +00:00
f1f97db627
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
From 800d5fb3c6a16661932c932bacd660e38d06b727 Mon Sep 17 00:00:00 2001
|
|
From: Markus Stockhausen <markus.stockhausen@gmx.de>
|
|
Date: Thu, 25 Aug 2022 08:22:36 +0200
|
|
Subject: [PATCH] realtek: add patch to enable new clock driver in kernel
|
|
|
|
Allow building the clock driver with kernel config options.
|
|
|
|
Submitted-by: Markus Stockhausen <markus.stockhausen@gmx.de>
|
|
---
|
|
drivers/clk/Kconfig | 1 +
|
|
drivers/clk/Makefile | 1 +
|
|
2 files changed, 2 insertions(+)
|
|
|
|
--- a/drivers/clk/Kconfig
|
|
+++ b/drivers/clk/Kconfig
|
|
@@ -372,6 +372,7 @@ source "drivers/clk/mediatek/Kconfig"
|
|
source "drivers/clk/meson/Kconfig"
|
|
source "drivers/clk/mvebu/Kconfig"
|
|
source "drivers/clk/qcom/Kconfig"
|
|
+source "drivers/clk/realtek/Kconfig"
|
|
source "drivers/clk/renesas/Kconfig"
|
|
source "drivers/clk/rockchip/Kconfig"
|
|
source "drivers/clk/samsung/Kconfig"
|
|
--- a/drivers/clk/Makefile
|
|
+++ b/drivers/clk/Makefile
|
|
@@ -100,6 +100,7 @@ obj-$(CONFIG_COMMON_CLK_NXP) += nxp/
|
|
obj-$(CONFIG_MACH_PISTACHIO) += pistachio/
|
|
obj-$(CONFIG_COMMON_CLK_PXA) += pxa/
|
|
obj-$(CONFIG_COMMON_CLK_QCOM) += qcom/
|
|
+obj-$(CONFIG_COMMON_CLK_REALTEK) += realtek/
|
|
obj-y += renesas/
|
|
obj-$(CONFIG_ARCH_ROCKCHIP) += rockchip/
|
|
obj-$(CONFIG_COMMON_CLK_SAMSUNG) += samsung/
|