mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-27 01:11:14 +00:00
f1f97db627
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
23 lines
988 B
Diff
23 lines
988 B
Diff
From 2cd00b51470a30198b048a5fca48a04db77e29cc Mon Sep 17 00:00:00 2001
|
|
From: INAGAKI Hiroshi <musashino.open@gmail.com>
|
|
Date: Fri, 21 May 2021 23:16:37 +0900
|
|
Subject: [PATCH] realtek: backport irq-realtek-rtl driver from 5.12 to 5.10
|
|
|
|
This patch backports "irq-realtek-rtl" driver to Kernel 5.10 from 5.12.
|
|
"MACH_REALTEK_RTL" is used as a platform name in upstream, but "RTL838X"
|
|
is used in OpenWrt, so update the dependency by the additional patch.
|
|
|
|
Submitted-by: INAGAKI Hiroshi <musashino.open@gmail.com>
|
|
---
|
|
drivers/irqchip/Makefile | 2 +-
|
|
1 files changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/drivers/irqchip/Makefile
|
|
+++ b/drivers/irqchip/Makefile
|
|
@@ -114,4 +114,4 @@ obj-$(CONFIG_LOONGSON_PCH_PIC) += irq-l
|
|
obj-$(CONFIG_LOONGSON_PCH_MSI) += irq-loongson-pch-msi.o
|
|
obj-$(CONFIG_MST_IRQ) += irq-mst-intc.o
|
|
obj-$(CONFIG_SL28CPLD_INTC) += irq-sl28cpld.o
|
|
-obj-$(CONFIG_MACH_REALTEK_RTL) += irq-realtek-rtl.o
|
|
+obj-$(CONFIG_RTL83XX) += irq-realtek-rtl.o
|