mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
6aec3c7b5b
Move fip and factory into UBI static volumes. Use fitblk instead of partition parser. !! RUN INSTALLER FIRST !! Existing users of previous OpenWrt releases or snapshot builds will have to **re-run the updated installer** before upgrading to firmware after this commit. DO NOT flash or run even just the initramfs image unless you have run the updated installer which moves the content of the 'factory' partition into a UBI volume. tl;dr: DON'T USE YET! Signed-off-by: Daniel Golle <daniel@makrotopia.org>
429 lines
13 KiB
Diff
429 lines
13 KiB
Diff
--- /dev/null
|
||
+++ b/configs/mt7622_linksys_e8450_defconfig
|
||
@@ -0,0 +1,140 @@
|
||
+CONFIG_ARM=y
|
||
+CONFIG_POSITION_INDEPENDENT=y
|
||
+CONFIG_ARCH_MEDIATEK=y
|
||
+CONFIG_TARGET_MT7622=y
|
||
+CONFIG_TEXT_BASE=0x41e00000
|
||
+CONFIG_SYS_MALLOC_F_LEN=0x4000
|
||
+CONFIG_SYS_LOAD_ADDR=0x40080000
|
||
+CONFIG_USE_DEFAULT_ENV_FILE=y
|
||
+CONFIG_BOARD_LATE_INIT=y
|
||
+CONFIG_BOOTP_SEND_HOSTNAME=y
|
||
+CONFIG_DEFAULT_ENV_FILE="linksys_e8450_env"
|
||
+CONFIG_NR_DRAM_BANKS=1
|
||
+CONFIG_DEBUG_UART_BASE=0x11002000
|
||
+CONFIG_DEBUG_UART_CLOCK=25000000
|
||
+CONFIG_DEFAULT_DEVICE_TREE="mt7622-linksys-e8450-ubi"
|
||
+CONFIG_DEBUG_UART=y
|
||
+CONFIG_SMBIOS_PRODUCT_NAME=""
|
||
+CONFIG_AUTOBOOT_KEYED=y
|
||
+CONFIG_BOOTDELAY=30
|
||
+CONFIG_AUTOBOOT_MENU_SHOW=y
|
||
+CONFIG_CFB_CONSOLE_ANSI=y
|
||
+CONFIG_BUTTON=y
|
||
+CONFIG_BUTTON_GPIO=y
|
||
+CONFIG_GPIO_HOG=y
|
||
+CONFIG_CMD_ENV_FLAGS=y
|
||
+CONFIG_FIT=y
|
||
+CONFIG_FIT_ENABLE_SHA256_SUPPORT=y
|
||
+CONFIG_LED=y
|
||
+CONFIG_LED_BLINK=y
|
||
+CONFIG_LED_GPIO=y
|
||
+CONFIG_LOGLEVEL=7
|
||
+CONFIG_LOG=y
|
||
+CONFIG_DEFAULT_FDT_FILE="mt7622-linksys-e8450"
|
||
+CONFIG_SYS_PROMPT="MT7622> "
|
||
+CONFIG_CMD_BOOTMENU=y
|
||
+CONFIG_CMD_BOOTP=y
|
||
+CONFIG_CMD_BUTTON=y
|
||
+CONFIG_CMD_CDP=y
|
||
+CONFIG_CMD_DHCP=y
|
||
+CONFIG_CMD_DNS=y
|
||
+CONFIG_CMD_ECHO=y
|
||
+CONFIG_CMD_ENV_READMEM=y
|
||
+CONFIG_CMD_ERASEENV=y
|
||
+CONFIG_CMD_EXT4=y
|
||
+CONFIG_CMD_FAT=y
|
||
+CONFIG_CMD_FS_GENERIC=y
|
||
+CONFIG_CMD_FS_UUID=y
|
||
+CONFIG_CMD_GPIO=y
|
||
+CONFIG_CMD_GPT=y
|
||
+CONFIG_CMD_HASH=y
|
||
+CONFIG_CMD_ITEST=y
|
||
+CONFIG_CMD_LED=y
|
||
+CONFIG_CMD_LICENSE=y
|
||
+CONFIG_CMD_LINK_LOCAL=y
|
||
+# CONFIG_CMD_MBR is not set
|
||
+CONFIG_CMD_MTD=y
|
||
+CONFIG_CMD_MTDPARTS=y
|
||
+CONFIG_CMD_PCI=y
|
||
+CONFIG_CMD_SF_TEST=y
|
||
+CONFIG_CMD_PING=y
|
||
+CONFIG_CMD_PXE=y
|
||
+CONFIG_CMD_SMC=y
|
||
+CONFIG_CMD_TFTPBOOT=y
|
||
+CONFIG_CMD_TFTPSRV=y
|
||
+CONFIG_CMD_UBI=y
|
||
+CONFIG_CMD_UBI_RENAME=y
|
||
+CONFIG_CMD_UBIFS=y
|
||
+CONFIG_CMD_ASKENV=y
|
||
+CONFIG_CMD_PART=y
|
||
+CONFIG_CMD_PSTORE=y
|
||
+CONFIG_CMD_PSTORE_MEM_ADDR=0x42ff0000
|
||
+CONFIG_CMD_RARP=y
|
||
+CONFIG_CMD_SETEXPR=y
|
||
+CONFIG_CMD_SLEEP=y
|
||
+CONFIG_CMD_SNTP=y
|
||
+CONFIG_CMD_SOURCE=y
|
||
+CONFIG_CMD_USB=y
|
||
+CONFIG_CMD_UUID=y
|
||
+CONFIG_DISPLAY_CPUINFO=y
|
||
+CONFIG_DM_REGULATOR=y
|
||
+CONFIG_DM_REGULATOR_FIXED=y
|
||
+CONFIG_DM_REGULATOR_GPIO=y
|
||
+CONFIG_DM_USB=y
|
||
+CONFIG_HUSH_PARSER=y
|
||
+CONFIG_SYS_REDUNDAND_ENVIRONMENT=y
|
||
+CONFIG_SYS_RELOC_GD_ENV_ADDR=y
|
||
+CONFIG_ENV_IS_IN_UBI=y
|
||
+CONFIG_ENV_UBI_PART="ubi"
|
||
+CONFIG_ENV_UBI_VOLUME="ubootenv"
|
||
+CONFIG_ENV_UBI_VOLUME_REDUND="ubootenv2"
|
||
+CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG=y
|
||
+CONFIG_VERSION_VARIABLE=y
|
||
+CONFIG_PARTITION_UUIDS=y
|
||
+CONFIG_NETCONSOLE=y
|
||
+CONFIG_REGMAP=y
|
||
+CONFIG_SYSCON=y
|
||
+CONFIG_CLK=y
|
||
+CONFIG_DM_MTD=y
|
||
+CONFIG_DM_GPIO=y
|
||
+CONFIG_PHY=y
|
||
+CONFIG_PHY_MTK_TPHY=y
|
||
+CONFIG_PHY_FIXED=y
|
||
+CONFIG_DM_ETH=y
|
||
+CONFIG_MEDIATEK_ETH=y
|
||
+CONFIG_PCI=y
|
||
+CONFIG_MTD=y
|
||
+CONFIG_MTD_UBI_FASTMAP=y
|
||
+CONFIG_DM_PCI=y
|
||
+CONFIG_PCIE_MEDIATEK=y
|
||
+CONFIG_PINCTRL=y
|
||
+CONFIG_PINCONF=y
|
||
+CONFIG_PINCTRL_MT7622=y
|
||
+CONFIG_POWER_DOMAIN=y
|
||
+CONFIG_PRE_CONSOLE_BUFFER=y
|
||
+CONFIG_PRE_CON_BUF_ADDR=0x4007EF00
|
||
+CONFIG_MTK_POWER_DOMAIN=y
|
||
+CONFIG_RAM=y
|
||
+CONFIG_DM_SERIAL=y
|
||
+CONFIG_MTK_SERIAL=y
|
||
+CONFIG_SPI=y
|
||
+CONFIG_DM_SPI=y
|
||
+CONFIG_MTK_SPI_NAND=y
|
||
+CONFIG_MTK_SPI_NAND_MTD=y
|
||
+CONFIG_SYSRESET_WATCHDOG=y
|
||
+CONFIG_SYS_HAS_NONCACHED_MEMORY=y
|
||
+CONFIG_WDT_MTK=y
|
||
+CONFIG_LZO=y
|
||
+CONFIG_ZSTD=y
|
||
+CONFIG_HEXDUMP=y
|
||
+CONFIG_RANDOM_UUID=y
|
||
+CONFIG_REGEX=y
|
||
+CONFIG_USE_IPADDR=y
|
||
+CONFIG_IPADDR="192.168.1.1"
|
||
+CONFIG_USE_SERVERIP=y
|
||
+CONFIG_SERVERIP="192.168.1.254"
|
||
+CONFIG_USB=y
|
||
+CONFIG_USB_HOST=y
|
||
+CONFIG_USB_XHCI_HCD=y
|
||
+CONFIG_USB_XHCI_MTK=y
|
||
+CONFIG_USB_STORAGE=y
|
||
--- /dev/null
|
||
+++ b/arch/arm/dts/mt7622-linksys-e8450-ubi.dts
|
||
@@ -0,0 +1,214 @@
|
||
+// SPDX-License-Identifier: GPL-2.0
|
||
+/*
|
||
+ * Copyright (c) 2019 MediaTek Inc.
|
||
+ * Author: Sam Shih <sam.shih@mediatek.com>
|
||
+ */
|
||
+
|
||
+/dts-v1/;
|
||
+#include <dt-bindings/input/linux-event-codes.h>
|
||
+#include "mt7622.dtsi"
|
||
+#include "mt7622-u-boot.dtsi"
|
||
+
|
||
+/ {
|
||
+ #address-cells = <1>;
|
||
+ #size-cells = <1>;
|
||
+ model = "mt7622-linksys-e8450-ubi";
|
||
+ compatible = "mediatek,mt7622", "linksys,e8450-ubi";
|
||
+ chosen {
|
||
+ stdout-path = &uart0;
|
||
+ tick-timer = &timer0;
|
||
+ };
|
||
+
|
||
+ aliases {
|
||
+ spi0 = &snand;
|
||
+ };
|
||
+
|
||
+ gpio-keys {
|
||
+ compatible = "gpio-keys";
|
||
+
|
||
+ factory {
|
||
+ label = "reset";
|
||
+ gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
|
||
+ linux,code = <KEY_RESTART>;
|
||
+ };
|
||
+
|
||
+ wps {
|
||
+ label = "wps";
|
||
+ gpios = <&gpio 102 GPIO_ACTIVE_LOW>;
|
||
+ linux,code = <KEY_WPS_BUTTON>;
|
||
+ };
|
||
+ };
|
||
+
|
||
+ gpio-leds {
|
||
+ compatible = "gpio-leds";
|
||
+
|
||
+ led_power: power_blue {
|
||
+ label = "power:blue";
|
||
+ gpios = <&gpio 95 GPIO_ACTIVE_LOW>;
|
||
+ default-state = "on";
|
||
+ };
|
||
+
|
||
+ power_orange {
|
||
+ label = "power:orange";
|
||
+ gpios = <&gpio 96 GPIO_ACTIVE_LOW>;
|
||
+ default-state = "off";
|
||
+ };
|
||
+
|
||
+ inet_blue {
|
||
+ label = "inet:blue";
|
||
+ gpios = <&gpio 97 GPIO_ACTIVE_LOW>;
|
||
+ default-state = "off";
|
||
+ };
|
||
+
|
||
+ inet_orange {
|
||
+ label = "inet:orange";
|
||
+ gpios = <&gpio 98 GPIO_ACTIVE_LOW>;
|
||
+ default-state = "off";
|
||
+ };
|
||
+ };
|
||
+
|
||
+ memory@40000000 {
|
||
+ device_type = "memory";
|
||
+ reg = <0x40000000 0x20000000>;
|
||
+ };
|
||
+
|
||
+ reg_1p8v: regulator-1p8v {
|
||
+ compatible = "regulator-fixed";
|
||
+ regulator-name = "fixed-1.8V";
|
||
+ regulator-min-microvolt = <1800000>;
|
||
+ regulator-max-microvolt = <1800000>;
|
||
+ regulator-boot-on;
|
||
+ regulator-always-on;
|
||
+ };
|
||
+
|
||
+ reg_3p3v: regulator-3p3v {
|
||
+ compatible = "regulator-fixed";
|
||
+ regulator-name = "fixed-3.3V";
|
||
+ regulator-min-microvolt = <3300000>;
|
||
+ regulator-max-microvolt = <3300000>;
|
||
+ regulator-boot-on;
|
||
+ regulator-always-on;
|
||
+ };
|
||
+
|
||
+ reg_5v: regulator-5v {
|
||
+ compatible = "regulator-fixed";
|
||
+ regulator-name = "fixed-5V";
|
||
+ regulator-min-microvolt = <5000000>;
|
||
+ regulator-max-microvolt = <5000000>;
|
||
+ regulator-boot-on;
|
||
+ regulator-always-on;
|
||
+ };
|
||
+};
|
||
+
|
||
+&pcie {
|
||
+ pinctrl-names = "default";
|
||
+ pinctrl-0 = <&pcie0_pins>, <&pcie1_pins>;
|
||
+ status = "okay";
|
||
+
|
||
+ pcie@0,0 {
|
||
+ status = "okay";
|
||
+ };
|
||
+
|
||
+ pcie@1,0 {
|
||
+ status = "okay";
|
||
+ };
|
||
+};
|
||
+
|
||
+&pinctrl {
|
||
+ pcie0_pins: pcie0-pins {
|
||
+ mux {
|
||
+ function = "pcie";
|
||
+ groups = "pcie0_pad_perst",
|
||
+ "pcie0_1_waken",
|
||
+ "pcie0_1_clkreq";
|
||
+ };
|
||
+ };
|
||
+
|
||
+ pcie1_pins: pcie1-pins {
|
||
+ mux {
|
||
+ function = "pcie";
|
||
+ groups = "pcie1_pad_perst",
|
||
+ "pcie1_0_waken",
|
||
+ "pcie1_0_clkreq";
|
||
+ };
|
||
+ };
|
||
+
|
||
+ snfi_pins: snfi-pins {
|
||
+ mux {
|
||
+ function = "flash";
|
||
+ groups = "snfi";
|
||
+ };
|
||
+ };
|
||
+
|
||
+ uart0_pins: uart0 {
|
||
+ mux {
|
||
+ function = "uart";
|
||
+ groups = "uart0_0_tx_rx" ;
|
||
+ };
|
||
+ };
|
||
+
|
||
+ watchdog_pins: watchdog-default {
|
||
+ mux {
|
||
+ function = "watchdog";
|
||
+ groups = "watchdog";
|
||
+ };
|
||
+ };
|
||
+};
|
||
+
|
||
+&snand {
|
||
+ pinctrl-names = "default";
|
||
+ pinctrl-0 = <&snfi_pins>;
|
||
+ status = "okay";
|
||
+ quad-spi;
|
||
+
|
||
+ partitions {
|
||
+ compatible = "fixed-partitions";
|
||
+ #address-cells = <1>;
|
||
+ #size-cells = <1>;
|
||
+
|
||
+ partition@0 {
|
||
+ label = "bl2";
|
||
+ reg = <0x0 0x80000>;
|
||
+ };
|
||
+
|
||
+ partition@80000 {
|
||
+ label = "ubi";
|
||
+ reg = <0x80000 0x7f80000>;
|
||
+ compatible = "linux,ubi";
|
||
+ };
|
||
+ };
|
||
+};
|
||
+
|
||
+&uart0 {
|
||
+ mediatek,force-highspeed;
|
||
+ status = "okay";
|
||
+};
|
||
+
|
||
+&watchdog {
|
||
+ pinctrl-names = "default";
|
||
+ pinctrl-0 = <&watchdog_pins>;
|
||
+ status = "okay";
|
||
+};
|
||
+
|
||
+ð {
|
||
+ status = "okay";
|
||
+ mediatek,gmac-id = <0>;
|
||
+ phy-mode = "2500base-x";
|
||
+ mediatek,switch = "mt7531";
|
||
+ reset-gpios = <&gpio 54 GPIO_ACTIVE_HIGH>;
|
||
+
|
||
+ fixed-link {
|
||
+ speed = <2500>;
|
||
+ full-duplex;
|
||
+ };
|
||
+};
|
||
+
|
||
+&ssusb {
|
||
+ vusb33-supply = <®_3p3v>;
|
||
+ vbus-supply = <®_5v>;
|
||
+ status = "okay";
|
||
+};
|
||
+
|
||
+&u3phy {
|
||
+ status = "okay";
|
||
+};
|
||
--- a/arch/arm/dts/Makefile
|
||
+++ b/arch/arm/dts/Makefile
|
||
@@ -1422,6 +1422,7 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += \
|
||
mt7622-rfb.dtb \
|
||
mt7623a-unielec-u7623-02-emmc.dtb \
|
||
mt7622-bananapi-bpi-r64.dtb \
|
||
+ mt7622-linksys-e8450-ubi.dtb \
|
||
mt7623n-bananapi-bpi-r2.dtb \
|
||
mt7629-rfb.dtb \
|
||
mt7981-rfb.dtb \
|
||
--- /dev/null
|
||
+++ b/linksys_e8450_env
|
||
@@ -0,0 +1,54 @@
|
||
+ethaddr_factory=ubi read 0x40080000 factory && env readmem -b ethaddr 0x400ffff4 0x6 ; setenv ethaddr_factory
|
||
+ipaddr=192.168.1.1
|
||
+serverip=192.168.1.254
|
||
+loadaddr=0x48000000
|
||
+bootcmd=if pstore check ; then run boot_recovery ; else run boot_ubi ; fi
|
||
+bootconf=config-1
|
||
+bootdelay=0
|
||
+bootfile=openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb
|
||
+bootfile_bl2=openwrt-mediatek-mt7622-linksys_e8450-ubi-preloader.bin
|
||
+bootfile_fip=openwrt-mediatek-mt7622-linksys_e8450-ubi-bl31-uboot.fip
|
||
+bootfile_upg=openwrt-mediatek-mt7622-linksys_e8450-ubi-squashfs-sysupgrade.itb
|
||
+bootled_pwr=power:blue
|
||
+bootled_rec=inet:orange on
|
||
+bootmenu_confirm_return=askenv - Press ENTER to return to menu ; bootmenu 60
|
||
+bootmenu_default=0
|
||
+bootmenu_delay=0
|
||
+bootmenu_title= [0;34m( ( ( [1;39mOpenWrt[0;34m ) ) )[0m
|
||
+bootmenu_0=Initialize environment.=run _firstboot
|
||
+bootmenu_0d=Run default boot command.=run boot_default
|
||
+bootmenu_1=Boot system via TFTP.=run boot_tftp ; run bootmenu_confirm_return
|
||
+bootmenu_2=Boot production system from flash.=run boot_production ; run bootmenu_confirm_return
|
||
+bootmenu_3=Boot recovery system from flash.=run boot_recovery ; run bootmenu_confirm_return
|
||
+bootmenu_4=Load production system via TFTP then write to flash.=setenv noboot 1 ; setenv replacevol 1 ; run boot_tftp_production ; setenv noboot ; setenv replacevol ; run bootmenu_confirm_return
|
||
+bootmenu_5=Load recovery system via TFTP then write to flash.=setenv noboot 1 ; setenv replacevol 1 ; run boot_tftp_recovery ; setenv noboot ; setenv replacevol ; run bootmenu_confirm_return
|
||
+bootmenu_6=[31mLoad BL31+U-Boot FIP via TFTP then write to flash.[0m=run boot_tftp_write_fip ; run bootmenu_confirm_return
|
||
+bootmenu_7=[31mLoad BL2 preloader via TFTP then write to flash.[0m=run boot_tftp_write_bl2 ; run bootmenu_confirm_return
|
||
+bootmenu_8=Reboot.=reset
|
||
+bootmenu_9=Reset all settings to factory defaults.=run reset_factory ; reset
|
||
+boot_first=if button reset ; then led $bootled_rec on ; run boot_tftp_recovery ; setenv flag_recover 1 ; run boot_default ; fi ; bootmenu
|
||
+boot_default=if env exists flag_recover ; then else run bootcmd ; fi ; run boot_recovery ; setenv replacevol 1 ; run boot_tftp_forever
|
||
+boot_production=led $bootled_pwr on ; run ubi_read_production && bootm $loadaddr#$bootconf ; led $bootled_pwr off
|
||
+boot_recovery=led $bootled_rec on ; run ubi_read_recovery ; bootm $loadaddr#$bootconf ; ubi remove recovery ; led $bootled_rec off
|
||
+boot_serial_write_bl2=loadx $loadaddr 115200 && run snand_write_bl2
|
||
+boot_serial_write_fip=loadx $loadaddr 115200 && run ubi_write_fip
|
||
+boot_tftp=tftpboot $loadaddr $bootfile && bootm $loadaddr#$bootconf
|
||
+boot_tftp_forever=led $bootled_rec on ; while true ; do run boot_tftp_recovery ; sleep 1 ; done
|
||
+boot_tftp_production=tftpboot $loadaddr $bootfile_upg && iminfo $loadaddr && ubi part ubi && run ubi_write_production ubi_prepare_rootfs ; if env exists noboot ; then else bootm $loadaddr#$bootconf ; fi
|
||
+boot_tftp_recovery=tftpboot $loadaddr $bootfile && iminfo $loadaddr && ubi part ubi && run ubi_write_recovery ; if env exists noboot ; then else bootm $loadaddr#$bootconf ; fi
|
||
+boot_tftp_write_bl2=tftpboot $loadaddr $bootfile_bl2 && run snand_write_bl2
|
||
+boot_tftp_write_fip=tftpboot $loadaddr $bootfile_fip && run ubi_write_fip
|
||
+boot_ubi=ubi part ubi && run boot_production ; run boot_recovery
|
||
+snand_write_bl2=mtd erase bl2 && mtd write spi-nand0 $loadaddr 0x0 0x20000 && mtd write spi-nand0 $loadaddr 0x20000 0x20000 && mtd write spi-nand0 $loadaddr 0x40000 0x20000 && mtd write spi-nand0 $loadaddr 0x60000 0x20000
|
||
+reset_factory=mw $loadaddr 0xff 0x1f000 ; ubi part ubi ; ubi write $loadaddr ubootenv 0x1f000 ; ubi write $loadaddr ubootenv2 0x1f000 ; ubi remove rootfs_data
|
||
+ubi_prepare_rootfs=if ubi check rootfs_data ; then else if env exists rootfs_data_max ; then ubi create rootfs_data $rootfs_data_max dynamic || ubi create rootfs_data - dynamic ; else ubi create rootfs_data - dynamic ; fi ; fi
|
||
+ubi_read_production=ubi read $loadaddr fit && iminfo $loadaddr && run ubi_prepare_rootfs
|
||
+ubi_read_recovery=ubi check recovery && ubi read $loadaddr recovery
|
||
+ubi_remove_rootfs=ubi check rootfs_data && ubi remove rootfs_data
|
||
+ubi_write_fip=ubi check fip || ubi create fip 0x200000 static ; ubi write $loadaddr fip 0x200000
|
||
+ubi_write_production=ubi check fit && env exists replacevol && ubi remove fit ; if ubi check fit ; then else run ubi_remove_rootfs ; ubi create fit $filesize dynamic && ubi write $loadaddr fit $filesize ; fi
|
||
+ubi_write_recovery=ubi check recovery && env exists replacevol && ubi remove recovery ; if ubi check recovery ; then else run ubi_remove_rootfs ; ubi create recovery $filesize dynamic && ubi write $loadaddr recovery $filesize ; fi
|
||
+_create_env=ubi create ubootenv 0x1f000 dynamic ; ubi create ubootenv2 0x1f000 dynamic
|
||
+_init_env=setenv _init_env ; if ubi check ubootenv && ubi check ubootenv2 ; then else run _create_env ; fi ; setenv _create_env ; saveenv || run ubi_format ; saveenv || run ubi_format
|
||
+_firstboot=setenv _firstboot ; run _switch_to_menu ; run ethaddr_factory ; run _init_env ; run boot_first
|
||
+_switch_to_menu=setenv _switch_to_menu ; setenv bootdelay 3 ; setenv bootmenu_delay 3 ; setenv bootmenu_0 $bootmenu_0d ; setenv bootmenu_0d ; run _bootmenu_update_title
|
||
+_bootmenu_update_title=setenv _bootmenu_update_title ; setenv bootmenu_title "$bootmenu_title [33m$ver[0m"
|