mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
ae06a650d6
Use upstream latest git HEAD as it allows to remove the patches 700-radius-Prevent-buffer-overflow-in-rc_mksid, 701-pppd-Fix-bounds-check-in-EAP-code and 702-pppd-Ignore-received-EAP-messages-when-not-doing-EAP and take in other fixes. 41a7323 pppd: Fixed spelling 'unkown' => 'unknown' (#141) 6b014be pppd: Print version information to stdout instead of stderr (#133) cba2736 pppd: Add RFC1990 (Multilink) to the See Also section of the man page f2f9554 pppd: Add mppe.h to the list of headers to install if MPPE is defined ae54fcf pppd: Obfuscate password argument string 8d45443 pppd: Ignore received EAP messages when not doing EAP 8d7970b pppd: Fix bounds check in EAP code 858976b radius: Prevent buffer overflow in rc_mksid() Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
50 lines
1.6 KiB
Diff
50 lines
1.6 KiB
Diff
pppd: tune Linux config defaults for OpenWrt
|
|
|
|
This patch adjusts a number defaults to properly match the OpenWrt environment.
|
|
It is not intended for upstream.
|
|
|
|
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
|
|
|
|
--- a/pppd/Makefile.linux
|
|
+++ b/pppd/Makefile.linux
|
|
@@ -48,7 +48,7 @@ MPPE=y
|
|
# Uncomment the next line to include support for PPP packet filtering.
|
|
# This requires that the libpcap library and headers be installed
|
|
# and that the kernel driver support PPP packet filtering.
|
|
-FILTER=y
|
|
+#FILTER=y
|
|
|
|
# Uncomment the next line to enable multilink PPP (enabled by default)
|
|
# Linux distributions: Please leave multilink ENABLED in your builds
|
|
@@ -58,7 +58,7 @@ HAVE_MULTILINK=y
|
|
# Uncomment the next line to enable the TDB database (enabled by default.)
|
|
# If you enable multilink, then TDB is automatically enabled also.
|
|
# Linux distributions: Please leave TDB ENABLED in your builds.
|
|
-USE_TDB=y
|
|
+#USE_TDB=y
|
|
|
|
# Uncomment the next line to enable Type=notify services in systemd
|
|
# If enabled, and the user sets the up_sdnotify option, then
|
|
@@ -85,7 +85,7 @@ MAXOCTETS=y
|
|
|
|
INCLUDE_DIRS= -I../include
|
|
|
|
-COMPILE_FLAGS= -DHAVE_PATHS_H -DIPX_CHANGE -DHAVE_MMAP
|
|
+COMPILE_FLAGS= -DHAVE_PATHS_H -DHAVE_MMAP
|
|
|
|
CFLAGS= $(COPTS) $(COMPILE_FLAGS) $(INCLUDE_DIRS) '-DDESTDIR="@DESTDIR@"'
|
|
|
|
@@ -126,10 +126,10 @@ CFLAGS += -DHAS_SHADOW
|
|
#LIBS += -lshadow $(LIBS)
|
|
endif
|
|
|
|
-ifneq ($(wildcard $(shell $(CC) --print-sysroot)/usr/include/crypt.h),)
|
|
+#ifneq ($(wildcard $(shell $(CC) --print-sysroot)/usr/include/crypt.h),)
|
|
CFLAGS += -DHAVE_CRYPT_H=1
|
|
LIBS += -lcrypt
|
|
-endif
|
|
+#endif
|
|
|
|
ifdef USE_LIBUTIL
|
|
CFLAGS += -DHAVE_LOGWTMP=1
|