mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
ac7d45b5e7
This adds quirks support to the "ofpart" parser. It's required to support fixed partitions that require some extra logic. Right now only BCM4908 binding is supported (BCM4908 requires detecting currently used "firmware" partition). Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
39 lines
1.4 KiB
Diff
39 lines
1.4 KiB
Diff
From 4437e01fb6bca63fccdba5d6c44888b0935885c2 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Thibaut=20VAR=C3=88NE?= <hacks@slashdirt.org>
|
|
Date: Tue, 24 Mar 2020 11:45:07 +0100
|
|
Subject: [PATCH] generic: routerboot partition build bits (5.4)
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This patch adds routerbootpart kernel build bits
|
|
|
|
Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
|
|
---
|
|
drivers/mtd/parsers/Kconfig | 9 +++++++++
|
|
drivers/mtd/parsers/Makefile | 1 +
|
|
2 files changed, 10 insertions(+)
|
|
|
|
--- a/drivers/mtd/parsers/Kconfig
|
|
+++ b/drivers/mtd/parsers/Kconfig
|
|
@@ -176,3 +176,12 @@ config MTD_REDBOOT_PARTS_READONLY
|
|
'FIS directory' images, enable this option.
|
|
|
|
endif # MTD_REDBOOT_PARTS
|
|
+
|
|
+config MTD_ROUTERBOOT_PARTS
|
|
+ tristate "RouterBoot flash partition parser"
|
|
+ depends on MTD && OF
|
|
+ help
|
|
+ MikroTik RouterBoot is implemented as a multi segment system on the
|
|
+ flash, some of which are fixed and some of which are located at
|
|
+ variable offsets. This parser handles both cases via properly
|
|
+ formatted DTS.
|
|
--- a/drivers/mtd/parsers/Makefile
|
|
+++ b/drivers/mtd/parsers/Makefile
|
|
@@ -11,3 +11,4 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
|
|
obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
+obj-$(CONFIG_MTD_ROUTERBOOT_PARTS) += routerbootpart.o
|