mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
ab31547df0
libpath.so uses host path in ld script causing other packages fail to cross compile, e.g. perl: "ld: cannot find /usr/lib/libbsd.so.0.11.6: No such file or directory" Fixes: openwrt/packages#19390 Signed-off-by: Xuefer H <xuefer@gmail.com>
14 lines
443 B
Diff
14 lines
443 B
Diff
do not use host path to fix cross compiling
|
|
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -160,7 +160,7 @@
|
|
(echo '/* GNU ld script'; \
|
|
echo ' * The MD5 functions are provided by the libmd library. */'; \
|
|
cat format.ld; \
|
|
- echo "GROUP($(runtimelibdir)/$$soname AS_NEEDED($(MD5_LIBS)))"; \
|
|
+ echo "GROUP($$soname AS_NEEDED($(MD5_LIBS)))"; \
|
|
)>$(DESTDIR)$(libdir)/libbsd.so
|
|
else
|
|
if [ "$(libdir)" != "$(runtimelibdir)" ]; then \
|