mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 07:22:33 +00:00
aa528eec73
Adjust patches for kernel 5.15. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
41 lines
1.4 KiB
Diff
41 lines
1.4 KiB
Diff
--- a/drivers/clocksource/Kconfig
|
|
+++ b/drivers/clocksource/Kconfig
|
|
@@ -127,6 +127,17 @@ config RDA_TIMER
|
|
help
|
|
Enables the support for the RDA Micro timer driver.
|
|
|
|
+config REALTEK_OTTO_TIMER
|
|
+ bool "Clocksource/timer for the Realtek Otto platform"
|
|
+ select COMMON_CLK
|
|
+ select TIMER_OF
|
|
+ help
|
|
+ This driver adds support for the timers found in the Realtek RTL83xx
|
|
+ and RTL93xx SoCs series. This includes chips such as RTL8380, RTL8381
|
|
+ and RTL832, as well as chips from the RTL839x series, such as RTL8390
|
|
+ RT8391, RTL8392, RTL8393 and RTL8396 and chips of the RTL930x series
|
|
+ such as RTL9301, RTL9302 or RTL9303.
|
|
+
|
|
config SUN4I_TIMER
|
|
bool "Sun4i timer driver" if COMPILE_TEST
|
|
depends on HAS_IOMEM
|
|
--- a/drivers/clocksource/Makefile
|
|
+++ b/drivers/clocksource/Makefile
|
|
@@ -58,6 +58,7 @@ obj-$(CONFIG_MILBEAUT_TIMER) += timer-mi
|
|
obj-$(CONFIG_SPRD_TIMER) += timer-sprd.o
|
|
obj-$(CONFIG_NPCM7XX_TIMER) += timer-npcm7xx.o
|
|
obj-$(CONFIG_RDA_TIMER) += timer-rda.o
|
|
+obj-$(CONFIG_REALTEK_OTTO_TIMER) += timer-rtl-otto.o
|
|
|
|
obj-$(CONFIG_ARC_TIMERS) += arc_timer.o
|
|
obj-$(CONFIG_ARM_ARCH_TIMER) += arm_arch_timer.o
|
|
--- a/include/linux/cpuhotplug.h
|
|
+++ b/include/linux/cpuhotplug.h
|
|
@@ -177,6 +177,7 @@ enum cpuhp_state {
|
|
CPUHP_AP_MARCO_TIMER_STARTING,
|
|
CPUHP_AP_MIPS_GIC_TIMER_STARTING,
|
|
CPUHP_AP_ARC_TIMER_STARTING,
|
|
+ CPUHP_AP_REALTEK_TIMER_STARTING,
|
|
CPUHP_AP_RISCV_TIMER_STARTING,
|
|
CPUHP_AP_CLINT_TIMER_STARTING,
|
|
CPUHP_AP_CSKY_TIMER_STARTING,
|