mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
c2836c4d27
Add patch to reduce and improve selected bmips kernel config options. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
21 lines
701 B
Diff
21 lines
701 B
Diff
--- a/arch/mips/Kconfig
|
|
+++ b/arch/mips/Kconfig
|
|
@@ -274,6 +274,7 @@ config BMIPS_GENERIC
|
|
select SYNC_R4K
|
|
select COMMON_CLK
|
|
select BCM6345_L1_IRQ
|
|
+ select HAVE_PCI
|
|
select IRQ_MIPS_CPU
|
|
select DMA_NONCOHERENT
|
|
select SYS_SUPPORTS_32BIT_KERNEL
|
|
--- a/arch/mips/pci/Makefile
|
|
+++ b/arch/mips/pci/Makefile
|
|
@@ -28,6 +28,7 @@ obj-$(CONFIG_PCI_XTALK_BRIDGE) += pci-xt
|
|
# These are still pretty much in the old state, watch, go blind.
|
|
#
|
|
obj-$(CONFIG_ATH79) += fixup-ath79.o
|
|
+obj-$(CONFIG_BMIPS_GENERIC) += fixup-bmips.o
|
|
obj-$(CONFIG_MIPS_COBALT) += fixup-cobalt.o
|
|
obj-$(CONFIG_LEMOTE_FULOONG2E) += fixup-fuloong2e.o ops-loongson2.o
|
|
obj-$(CONFIG_LEMOTE_MACH2F) += fixup-lemote2f.o ops-loongson2.o
|