mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
169 lines
5.4 KiB
Diff
169 lines
5.4 KiB
Diff
From 9c8fd5fed9eab2705563f65ee898ef6ccce9333f Mon Sep 17 00:00:00 2001
|
|
From: DigitalDreamtime <clive.messer@digitaldreamtime.co.uk>
|
|
Date: Sat, 2 Jul 2016 16:26:19 +0100
|
|
Subject: [PATCH 078/454] Add support for Dion Audio LOCO DAC-AMP HAT
|
|
|
|
Using dedicated machine driver and pcm5102a codec driver.
|
|
|
|
Signed-off-by: DigitalDreamtime <clive.messer@digitaldreamtime.co.uk>
|
|
---
|
|
sound/soc/bcm/Kconfig | 7 ++
|
|
sound/soc/bcm/Makefile | 3 +-
|
|
sound/soc/bcm/dionaudio_loco.c | 121 +++++++++++++++++++++++++++++++++
|
|
3 files changed, 130 insertions(+), 1 deletion(-)
|
|
create mode 100644 sound/soc/bcm/dionaudio_loco.c
|
|
|
|
--- a/sound/soc/bcm/Kconfig
|
|
+++ b/sound/soc/bcm/Kconfig
|
|
@@ -117,3 +117,10 @@ config SND_DIGIDAC1_SOUNDCARD
|
|
select SND_SOC_WM8741
|
|
help
|
|
Say Y or M if you want to add support for Red Rocks Audio DigiDAC1 board.
|
|
+
|
|
+config SND_BCM2708_SOC_DIONAUDIO_LOCO
|
|
+ tristate "Support for Dion Audio LOCO DAC-AMP"
|
|
+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
+ select SND_SOC_PCM5102a
|
|
+ help
|
|
+ Say Y or M if you want to add support for Dion Audio LOCO.
|
|
--- a/sound/soc/bcm/Makefile
|
|
+++ b/sound/soc/bcm/Makefile
|
|
@@ -23,6 +23,7 @@ snd-soc-iqaudio-digi-objs := iqaudio_dig
|
|
snd-soc-raspidac3-objs := raspidac3.o
|
|
snd-soc-audioinjector-pi-soundcard-objs := audioinjector-pi-soundcard.o
|
|
snd-soc-digidac1-soundcard-objs := digidac1-soundcard.o
|
|
+snd-soc-dionaudio-loco-objs := dionaudio_loco.o
|
|
|
|
obj-$(CONFIG_SND_BCM2708_SOC_ADAU1977_ADC) += snd-soc-adau1977-adc.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_AMP) += snd-soc-hifiberry-amp.o
|
|
@@ -38,4 +39,4 @@ obj-$(CONFIG_SND_BCM2708_SOC_IQAUDIO_DIG
|
|
obj-$(CONFIG_SND_BCM2708_SOC_RASPIDAC3) += snd-soc-raspidac3.o
|
|
obj-$(CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD) += snd-soc-audioinjector-pi-soundcard.o
|
|
obj-$(CONFIG_SND_DIGIDAC1_SOUNDCARD) += snd-soc-digidac1-soundcard.o
|
|
-
|
|
+obj-$(CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO) += snd-soc-dionaudio-loco.o
|
|
--- /dev/null
|
|
+++ b/sound/soc/bcm/dionaudio_loco.c
|
|
@@ -0,0 +1,121 @@
|
|
+/*
|
|
+ * ASoC Driver for Dion Audio LOCO DAC-AMP
|
|
+ *
|
|
+ * Author: Miquel Blauw <info@dionaudio.nl>
|
|
+ * Copyright 2016
|
|
+ *
|
|
+ * Based on the software of the RPi-DAC writen by Florian Meier
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License
|
|
+ * version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful, but
|
|
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ * General Public License for more details.
|
|
+ */
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/platform_device.h>
|
|
+
|
|
+#include <sound/core.h>
|
|
+#include <sound/pcm.h>
|
|
+#include <sound/pcm_params.h>
|
|
+#include <sound/soc.h>
|
|
+#include <sound/jack.h>
|
|
+
|
|
+static int snd_rpi_dionaudio_loco_hw_params(
|
|
+ struct snd_pcm_substream *substream, struct snd_pcm_hw_params *params)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
|
|
+
|
|
+ unsigned int sample_bits =
|
|
+ snd_pcm_format_physical_width(params_format(params));
|
|
+
|
|
+ return snd_soc_dai_set_bclk_ratio(cpu_dai, sample_bits * 2);
|
|
+}
|
|
+
|
|
+/* machine stream operations */
|
|
+static struct snd_soc_ops snd_rpi_dionaudio_loco_ops = {
|
|
+ .hw_params = snd_rpi_dionaudio_loco_hw_params,
|
|
+};
|
|
+
|
|
+static struct snd_soc_dai_link snd_rpi_dionaudio_loco_dai[] = {
|
|
+{
|
|
+ .name = "DionAudio LOCO",
|
|
+ .stream_name = "DionAudio LOCO DAC-AMP",
|
|
+ .cpu_dai_name = "bcm2708-i2s.0",
|
|
+ .codec_dai_name = "pcm5102a-hifi",
|
|
+ .platform_name = "bcm2708-i2s.0",
|
|
+ .codec_name = "pcm5102a-codec",
|
|
+ .dai_fmt = SND_SOC_DAIFMT_I2S |
|
|
+ SND_SOC_DAIFMT_NB_NF |
|
|
+ SND_SOC_DAIFMT_CBS_CFS,
|
|
+ .ops = &snd_rpi_dionaudio_loco_ops,
|
|
+},
|
|
+};
|
|
+
|
|
+/* audio machine driver */
|
|
+static struct snd_soc_card snd_rpi_dionaudio_loco = {
|
|
+ .name = "snd_rpi_dionaudio_loco",
|
|
+ .dai_link = snd_rpi_dionaudio_loco_dai,
|
|
+ .num_links = ARRAY_SIZE(snd_rpi_dionaudio_loco_dai),
|
|
+};
|
|
+
|
|
+static int snd_rpi_dionaudio_loco_probe(struct platform_device *pdev)
|
|
+{
|
|
+ struct device_node *np;
|
|
+ int ret = 0;
|
|
+
|
|
+ snd_rpi_dionaudio_loco.dev = &pdev->dev;
|
|
+
|
|
+ np = pdev->dev.of_node;
|
|
+ if (np) {
|
|
+ struct snd_soc_dai_link *dai = &snd_rpi_dionaudio_loco_dai[0];
|
|
+ struct device_node *i2s_np;
|
|
+
|
|
+ i2s_np = of_parse_phandle(np, "i2s-controller", 0);
|
|
+ if (i2s_np) {
|
|
+ dai->cpu_dai_name = NULL;
|
|
+ dai->cpu_of_node = i2s_np;
|
|
+ dai->platform_name = NULL;
|
|
+ dai->platform_of_node = i2s_np;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ ret = snd_soc_register_card(&snd_rpi_dionaudio_loco);
|
|
+ if (ret && ret != -EPROBE_DEFER)
|
|
+ dev_err(&pdev->dev, "snd_soc_register_card() failed: %d\n",
|
|
+ ret);
|
|
+
|
|
+ return ret;
|
|
+}
|
|
+
|
|
+static int snd_rpi_dionaudio_loco_remove(struct platform_device *pdev)
|
|
+{
|
|
+ return snd_soc_unregister_card(&snd_rpi_dionaudio_loco);
|
|
+}
|
|
+
|
|
+static const struct of_device_id snd_rpi_dionaudio_loco_of_match[] = {
|
|
+ { .compatible = "dionaudio,loco-pcm5242-tpa3118", },
|
|
+ { /* sentinel */ },
|
|
+};
|
|
+MODULE_DEVICE_TABLE(of, snd_rpi_dionaudio_loco_of_match);
|
|
+
|
|
+static struct platform_driver snd_rpi_dionaudio_loco_driver = {
|
|
+ .driver = {
|
|
+ .name = "snd-dionaudio-loco",
|
|
+ .owner = THIS_MODULE,
|
|
+ .of_match_table = snd_rpi_dionaudio_loco_of_match,
|
|
+ },
|
|
+ .probe = snd_rpi_dionaudio_loco_probe,
|
|
+ .remove = snd_rpi_dionaudio_loco_remove,
|
|
+};
|
|
+
|
|
+module_platform_driver(snd_rpi_dionaudio_loco_driver);
|
|
+
|
|
+MODULE_AUTHOR("Miquel Blauw <info@dionaudio.nl>");
|
|
+MODULE_DESCRIPTION("ASoC Driver for DionAudio LOCO");
|
|
+MODULE_LICENSE("GPL v2");
|