mirror of
https://github.com/openwrt/openwrt.git
synced 2025-03-13 15:56:55 +00:00
Reworked: - 0034 patchset update Added: - 080 Add support for pinctrl-msm framework Removed: - 0074-ipq806x-usb-Control-USB-master-reset.patch (we now have a dedicated driver for qcom usb) - 0047-mtd-nand-Create-a-BBT-flag-to-access-bad-block-marke (merged upstream) - 310-msm-adhoc-bus-support (it looks like it was never actually used in any dts) Signed-off-by: Christian Lamparter <chunkeey@gmail.com> Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com> [commit subject and description facelift, SoB fix] Signed-off-by: Petr Štetiar <ynezz@true.cz>
116 lines
3.5 KiB
Diff
116 lines
3.5 KiB
Diff
From 36d68f64c411e09788687d5919886aadeb92adca Mon Sep 17 00:00:00 2001
|
|
From: Stephen Boyd <sboyd@codeaurora.org>
|
|
Date: Tue, 14 Aug 2018 17:42:20 +0530
|
|
Subject: [PATCH 01/12] ARM: Add Krait L2 register accessor functions
|
|
|
|
Krait CPUs have a handful of L2 cache controller registers that
|
|
live behind a cp15 based indirection register. First you program
|
|
the indirection register (l2cpselr) to point the L2 'window'
|
|
register (l2cpdr) at what you want to read/write. Then you
|
|
read/write the 'window' register to do what you want. The
|
|
l2cpselr register is not banked per-cpu so we must lock around
|
|
accesses to it to prevent other CPUs from re-pointing l2cpdr
|
|
underneath us.
|
|
|
|
Cc: Mark Rutland <mark.rutland@arm.com>
|
|
Cc: Russell King <linux@arm.linux.org.uk>
|
|
Acked-by: Bjorn Andersson <bjorn.andersson@linaro.org>
|
|
Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
|
|
Signed-off-by: Sricharan R <sricharan@codeaurora.org>
|
|
Tested-by: Craig Tatlor <ctatlor97@gmail.com>
|
|
Signed-off-by: Stephen Boyd <sboyd@kernel.org>
|
|
---
|
|
arch/arm/common/Kconfig | 3 ++
|
|
arch/arm/common/Makefile | 1 +
|
|
arch/arm/common/krait-l2-accessors.c | 48 +++++++++++++++++++++++
|
|
arch/arm/include/asm/krait-l2-accessors.h | 9 +++++
|
|
4 files changed, 61 insertions(+)
|
|
create mode 100644 arch/arm/common/krait-l2-accessors.c
|
|
create mode 100644 arch/arm/include/asm/krait-l2-accessors.h
|
|
|
|
--- a/arch/arm/common/Kconfig
|
|
+++ b/arch/arm/common/Kconfig
|
|
@@ -7,6 +7,9 @@ config DMABOUNCE
|
|
bool
|
|
select ZONE_DMA
|
|
|
|
+config KRAIT_L2_ACCESSORS
|
|
+ bool
|
|
+
|
|
config SHARP_LOCOMO
|
|
bool
|
|
|
|
--- a/arch/arm/common/Makefile
|
|
+++ b/arch/arm/common/Makefile
|
|
@@ -7,6 +7,7 @@ obj-y += firmware.o
|
|
|
|
obj-$(CONFIG_SA1111) += sa1111.o
|
|
obj-$(CONFIG_DMABOUNCE) += dmabounce.o
|
|
+obj-$(CONFIG_KRAIT_L2_ACCESSORS) += krait-l2-accessors.o
|
|
obj-$(CONFIG_SHARP_LOCOMO) += locomo.o
|
|
obj-$(CONFIG_SHARP_PARAM) += sharpsl_param.o
|
|
obj-$(CONFIG_SHARP_SCOOP) += scoop.o
|
|
--- /dev/null
|
|
+++ b/arch/arm/common/krait-l2-accessors.c
|
|
@@ -0,0 +1,48 @@
|
|
+// SPDX-License-Identifier: GPL-2.0
|
|
+// Copyright (c) 2018, The Linux Foundation. All rights reserved.
|
|
+
|
|
+#include <linux/spinlock.h>
|
|
+#include <linux/export.h>
|
|
+
|
|
+#include <asm/barrier.h>
|
|
+#include <asm/krait-l2-accessors.h>
|
|
+
|
|
+static DEFINE_RAW_SPINLOCK(krait_l2_lock);
|
|
+
|
|
+void krait_set_l2_indirect_reg(u32 addr, u32 val)
|
|
+{
|
|
+ unsigned long flags;
|
|
+
|
|
+ raw_spin_lock_irqsave(&krait_l2_lock, flags);
|
|
+ /*
|
|
+ * Select the L2 window by poking l2cpselr, then write to the window
|
|
+ * via l2cpdr.
|
|
+ */
|
|
+ asm volatile ("mcr p15, 3, %0, c15, c0, 6 @ l2cpselr" : : "r" (addr));
|
|
+ isb();
|
|
+ asm volatile ("mcr p15, 3, %0, c15, c0, 7 @ l2cpdr" : : "r" (val));
|
|
+ isb();
|
|
+
|
|
+ raw_spin_unlock_irqrestore(&krait_l2_lock, flags);
|
|
+}
|
|
+EXPORT_SYMBOL(krait_set_l2_indirect_reg);
|
|
+
|
|
+u32 krait_get_l2_indirect_reg(u32 addr)
|
|
+{
|
|
+ u32 val;
|
|
+ unsigned long flags;
|
|
+
|
|
+ raw_spin_lock_irqsave(&krait_l2_lock, flags);
|
|
+ /*
|
|
+ * Select the L2 window by poking l2cpselr, then read from the window
|
|
+ * via l2cpdr.
|
|
+ */
|
|
+ asm volatile ("mcr p15, 3, %0, c15, c0, 6 @ l2cpselr" : : "r" (addr));
|
|
+ isb();
|
|
+ asm volatile ("mrc p15, 3, %0, c15, c0, 7 @ l2cpdr" : "=r" (val));
|
|
+
|
|
+ raw_spin_unlock_irqrestore(&krait_l2_lock, flags);
|
|
+
|
|
+ return val;
|
|
+}
|
|
+EXPORT_SYMBOL(krait_get_l2_indirect_reg);
|
|
--- /dev/null
|
|
+++ b/arch/arm/include/asm/krait-l2-accessors.h
|
|
@@ -0,0 +1,9 @@
|
|
+/* SPDX-License-Identifier: GPL-2.0 */
|
|
+
|
|
+#ifndef __ASMARM_KRAIT_L2_ACCESSORS_H
|
|
+#define __ASMARM_KRAIT_L2_ACCESSORS_H
|
|
+
|
|
+extern void krait_set_l2_indirect_reg(u32 addr, u32 val);
|
|
+extern u32 krait_get_l2_indirect_reg(u32 addr);
|
|
+
|
|
+#endif
|