mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 17:01:14 +00:00
a736d912e2
SOC: IPQ4019 / QCA Dakota CPU: Quad-Core ARMv7 Processor rev 5 (v7l) Cortex-A7 DRAM: 256 MiB FLASH: NOR 4 MiB + NAND 128 MiB ETH: Qualcomm Atheros QCA8072 WLAN1: Qualcomm Atheros QCA4019 2.4GHz 802.11bgn 2:2x2 WLAN2: Qualcomm Atheros QCA4019 5GHz 802.11a/n/ac 2:2x2 WLAN2: Qualcomm Atheros QCA9888 5GHz 802.11a/n/ac 2:2x2 INPUT: WPS Button LEDS: Power, LAN1, LAN2, WLAN 2.4GHz, WLAN 5GHz-1, WLAN 5GHz-2, OPMODE 1. Load Ramdisk via U-Boot To set up the flash memory environment, do the following: a. As a preliminary step, ensure that the board console port is connected to the PC using these RS232 parameters: * 115200bps * 8N1 b. Confirm that the PC is connected to the board using one of the Ethernet ports. c. Set a static ip 192.168.99.8 for Ethernet that connects to board. d. The PC must have a TFTP server launched and listening on the interface to which the board is connected. e. At this stage power up the board and, after a few seconds, press 4 and then any key during the countdown. U-BOOT> set serverip 192.168.99.9 && tftpboot 0x84000000 192.168.99.8:openwrt.itb && bootm Signed-off-by: Steven Lin <steven.lin@senao.com> [copied 4.19 dts to 5.4] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
57 lines
1.7 KiB
Diff
57 lines
1.7 KiB
Diff
From a10fab12a927e60b7141a602e740d70cb4d09e4a Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Thu, 9 Mar 2017 11:03:18 +0100
|
|
Subject: [PATCH] arm: boot: add dts files
|
|
|
|
Signed-off-by: John Crispin <john@phrozen.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 23 +++++++++++++++++++++++
|
|
1 file changed, 23 insertions(+)
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -785,11 +785,43 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
|
qcom-apq8074-dragonboard.dtb \
|
|
qcom-apq8084-ifc6540.dtb \
|
|
qcom-apq8084-mtp.dtb \
|
|
+ qcom-ipq4018-a42.dtb \
|
|
+ qcom-ipq4018-ap120c-ac.dtb \
|
|
+ qcom-ipq4018-dap-2610.dtb \
|
|
+ qcom-ipq4018-cs-w3-wd1200g-eup.dtb \
|
|
+ qcom-ipq4018-ea6350v3.dtb \
|
|
+ qcom-ipq4018-eap1300.dtb \
|
|
+ qcom-ipq4018-emd1.dtb \
|
|
+ qcom-ipq4018-ens620ext.dtb \
|
|
+ qcom-ipq4018-ex6100v2.dtb \
|
|
+ qcom-ipq4018-ex6150v2.dtb \
|
|
+ qcom-ipq4018-fritzbox-4040.dtb \
|
|
+ qcom-ipq4018-jalapeno.dtb \
|
|
+ qcom-ipq4018-meshpoint-one.dtb \
|
|
+ qcom-ipq4018-nbg6617.dtb \
|
|
+ qcom-ipq4018-rt-ac58u.dtb \
|
|
+ qcom-ipq4018-wre6606.dtb \
|
|
qcom-ipq4019-ap.dk01.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk04.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk04.1-c3.dtb \
|
|
qcom-ipq4019-ap.dk07.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk07.1-c2.dtb \
|
|
+ qcom-ipq4019-a62.dtb \
|
|
+ qcom-ipq4019-eap2200.dtb \
|
|
+ qcom-ipq4019-fritzbox-7530.dtb \
|
|
+ qcom-ipq4019-fritzrepeater-1200.dtb \
|
|
+ qcom-ipq4019-fritzrepeater-3000.dtb \
|
|
+ qcom-ipq4019-ea8300.dtb \
|
|
+ qcom-ipq4019-map-ac2200.dtb \
|
|
+ qcom-ipq4019-e2600ac-c1.dtb \
|
|
+ qcom-ipq4019-e2600ac-c2.dtb \
|
|
+ qcom-ipq4019-u4019-32m.dtb \
|
|
+ qcom-ipq4019-wpj419.dtb \
|
|
+ qcom-ipq4028-wpj428.dtb \
|
|
+ qcom-ipq4029-ap-303.dtb \
|
|
+ qcom-ipq4029-ap-303h.dtb \
|
|
+ qcom-ipq4029-gl-b1300.dtb \
|
|
+ qcom-ipq4029-mr33.dtb \
|
|
qcom-ipq8064-ap148.dtb \
|
|
qcom-msm8660-surf.dtb \
|
|
qcom-msm8960-cdp.dtb \
|