mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 13:48:06 +00:00
5f59d28bc3
All kernel configs are refreshed by 'make kernel_oldconfig CONFIG_TARGET=target' and 'make kernel_oldconfig CONFIG_TARGET=subtarget'. upstreamed patches: 010-v5.17-spi-ar934x-fix-transfer-and-word-delays.patch 011-v5.17-spi-ar934x-fix-transfer-size.patch 020-v5.18-spi-ath79-Implement-the-spi_mem-interface.patch 030-v5.18-ath79-add-support-for-booting-QCN550x.patch build and run tested on: ath79/generic/ar7241 ath79/generic/qca9563 ath79/nand/ar9344 Signed-off-by: Shiji Yang <yangshiji66@qq.com>
35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
From: Gabor Juhos <juhosg@openwrt.org>
|
|
Subject: ar71xx: ar934x_nfc: experimental NAND Flash Controller driver for AR934x
|
|
|
|
SVN-Revision: 33385
|
|
---
|
|
drivers/mtd/nand/raw/Kconfig | 8 ++++++++
|
|
drivers/mtd/nand/raw/Makefile | 1 +
|
|
2 files changed, 9 insertions(+)
|
|
|
|
--- a/drivers/mtd/nand/raw/Kconfig
|
|
+++ b/drivers/mtd/nand/raw/Kconfig
|
|
@@ -557,4 +557,12 @@ config MTD_NAND_DISKONCHIP_BBTWRITE
|
|
load time (assuming you build diskonchip as a module) with the module
|
|
parameter "inftl_bbt_write=1".
|
|
|
|
+config MTD_NAND_AR934X
|
|
+ tristate "Support for NAND controller on Qualcomm Atheros AR934x/QCA955x SoCs"
|
|
+ depends on ATH79 || COMPILE_TEST
|
|
+ depends on HAS_IOMEM
|
|
+ help
|
|
+ Enables support for NAND controller on Qualcomm Atheros SoCs.
|
|
+ This controller is found on AR934x and QCA955x SoCs.
|
|
+
|
|
endif # MTD_RAW_NAND
|
|
--- a/drivers/mtd/nand/raw/Makefile
|
|
+++ b/drivers/mtd/nand/raw/Makefile
|
|
@@ -59,6 +59,7 @@ obj-$(CONFIG_MTD_NAND_INTEL_LGM) += inte
|
|
obj-$(CONFIG_MTD_NAND_ROCKCHIP) += rockchip-nand-controller.o
|
|
obj-$(CONFIG_MTD_NAND_PL35X) += pl35x-nand-controller.o
|
|
obj-$(CONFIG_MTD_NAND_RENESAS) += renesas-nand-controller.o
|
|
+obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nand.o
|
|
|
|
nand-objs := nand_base.o nand_legacy.o nand_bbt.o nand_timings.o nand_ids.o
|
|
nand-objs += nand_onfi.o
|