mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
44 lines
1.7 KiB
Diff
44 lines
1.7 KiB
Diff
From 3af0d509b5718cfe7fbaf8c97e769d3df3743de0 Mon Sep 17 00:00:00 2001
|
|
From: Thierry Reding <treding@nvidia.com>
|
|
Date: Fri, 1 Sep 2017 16:49:54 +0200
|
|
Subject: [PATCH 172/454] drm/vc4: Use correct path to trace include
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
The header comment in include/trace/define_trace.h specifies that the
|
|
TRACE_INCLUDE_PATH needs to be relative to the define_trace.h header
|
|
rather than the trace file including it. Most instances get that wrong
|
|
and work around it by adding the $(src) directory to the include path.
|
|
|
|
While this works, it is preferable to refer to the correct path to the
|
|
trace file in the first place and avoid any workaround.
|
|
|
|
Acked-by: Christian König <christian.koenig@amd.com>
|
|
Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch>
|
|
Signed-off-by: Thierry Reding <treding@nvidia.com>
|
|
Link: https://patchwork.freedesktop.org/patch/msgid/20170901144954.19620-6-thierry.reding@gmail.com
|
|
(cherry picked from commit ff58a15a502a900c35ff2f20182249b65719d6d7)
|
|
---
|
|
drivers/gpu/drm/vc4/Makefile | 2 --
|
|
drivers/gpu/drm/vc4/vc4_trace.h | 2 +-
|
|
2 files changed, 1 insertion(+), 3 deletions(-)
|
|
|
|
--- a/drivers/gpu/drm/vc4/Makefile
|
|
+++ b/drivers/gpu/drm/vc4/Makefile
|
|
@@ -26,5 +26,3 @@ vc4-y := \
|
|
vc4-$(CONFIG_DEBUG_FS) += vc4_debugfs.o
|
|
|
|
obj-$(CONFIG_DRM_VC4) += vc4.o
|
|
-
|
|
-CFLAGS_vc4_trace_points.o := -I$(src)
|
|
--- a/drivers/gpu/drm/vc4/vc4_trace.h
|
|
+++ b/drivers/gpu/drm/vc4/vc4_trace.h
|
|
@@ -59,5 +59,5 @@ TRACE_EVENT(vc4_wait_for_seqno_end,
|
|
|
|
/* This part must be outside protection */
|
|
#undef TRACE_INCLUDE_PATH
|
|
-#define TRACE_INCLUDE_PATH .
|
|
+#define TRACE_INCLUDE_PATH ../../drivers/gpu/drm/vc4
|
|
#include <trace/define_trace.h>
|