mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
106 lines
2.5 KiB
Diff
106 lines
2.5 KiB
Diff
From 921c7f42c3ed6cebea4edff86bbe2b6c1b882d53 Mon Sep 17 00:00:00 2001
|
|
From: Yevhen Kyriukha <kirgene@gmail.com>
|
|
Date: Sun, 14 Jan 2018 13:36:24 +0200
|
|
Subject: [PATCH 165/454] Added support for mbed AudioCODEC (TLV320AIC23B)
|
|
|
|
Signed-off-by: Yevhen Kyriukha <kirgene@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 6 ++
|
|
.../boot/dts/overlays/mbed-dac-overlay.dts | 64 +++++++++++++++++++
|
|
3 files changed, 71 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/mbed-dac-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -58,6 +58,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
justboom-dac.dtbo \
|
|
justboom-digi.dtbo \
|
|
lirc-rpi.dtbo \
|
|
+ mbed-dac.dtbo \
|
|
mcp23017.dtbo \
|
|
mcp23s17.dtbo \
|
|
mcp2515-can0.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -965,6 +965,12 @@ Params: gpio_out_pin GPIO for
|
|
(default "off")
|
|
|
|
|
|
+Name: mbed-dac
|
|
+Info: Configures the mbed AudioCODEC (TLV320AIC23B)
|
|
+Load: dtoverlay=mbed-dac
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: mcp23017
|
|
Info: Configures the MCP23017 I2C GPIO expander
|
|
Load: dtoverlay=mcp23017,<param>=<val>
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/mbed-dac-overlay.dts
|
|
@@ -0,0 +1,64 @@
|
|
+// Definitions for mbed DAC
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&i2s>;
|
|
+ __overlay__ {
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&i2c1>;
|
|
+ __overlay__ {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ status = "okay";
|
|
+
|
|
+ tlv320aic23: codec@1a {
|
|
+ #sound-dai-cells = <0>;
|
|
+ reg = <0x1a>;
|
|
+ compatible = "ti,tlv320aic23";
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@2 {
|
|
+ target = <&sound>;
|
|
+ __overlay__ {
|
|
+ compatible = "simple-audio-card";
|
|
+ i2s-controller = <&i2s>;
|
|
+ status = "okay";
|
|
+
|
|
+ simple-audio-card,name = "mbed-DAC";
|
|
+
|
|
+ simple-audio-card,widgets =
|
|
+ "Microphone", "Mic Jack",
|
|
+ "Line", "Line In",
|
|
+ "Headphone", "Headphone Jack";
|
|
+
|
|
+ simple-audio-card,routing =
|
|
+ "Headphone Jack", "LHPOUT",
|
|
+ "Headphone Jack", "RHPOUT",
|
|
+ "LLINEIN", "Line In",
|
|
+ "RLINEIN", "Line In",
|
|
+ "MICIN", "Mic Jack";
|
|
+
|
|
+ simple-audio-card,format = "i2s";
|
|
+
|
|
+ simple-audio-card,cpu {
|
|
+ sound-dai = <&i2s>;
|
|
+ };
|
|
+
|
|
+ sound_master: simple-audio-card,codec {
|
|
+ sound-dai = <&tlv320aic23>;
|
|
+ system-clock-frequency = <12288000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|