mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
cccf98c7e8
Backport patch adding support for the AQR114C PHY and add support for PHY LEDs and polarity setting of Aquantia 3rd and 4th generation PHYs. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
369 lines
12 KiB
Diff
369 lines
12 KiB
Diff
From c6a1759365fc35463138a7d9e335ee53f384b8df Mon Sep 17 00:00:00 2001
|
|
From: Daniel Golle <daniel@makrotopia.org>
|
|
Date: Fri, 10 May 2024 02:53:52 +0100
|
|
Subject: [PATCH] net: phy: aquantia: add support for PHY LEDs
|
|
|
|
Aquantia Ethernet PHYs got 3 LED output pins which are typically used
|
|
to indicate link status and activity.
|
|
Add a minimal LED controller driver supporting the most common uses
|
|
with the 'netdev' trigger as well as software-driven forced control of
|
|
the LEDs.
|
|
|
|
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|
---
|
|
drivers/net/phy/aquantia/Makefile | 3 +
|
|
drivers/net/phy/aquantia/aquantia.h | 84 +++++++++++++
|
|
drivers/net/phy/aquantia/aquantia_leds.c | 152 +++++++++++++++++++++++
|
|
drivers/net/phy/aquantia/aquantia_main.c | 127 +++++++++++++------
|
|
4 files changed, 329 insertions(+), 37 deletions(-)
|
|
create mode 100644 drivers/net/phy/aquantia/aquantia_leds.c
|
|
|
|
--- a/drivers/net/phy/aquantia/Makefile
|
|
+++ b/drivers/net/phy/aquantia/Makefile
|
|
@@ -3,4 +3,7 @@ aquantia-objs += aquantia_main.o aquan
|
|
ifdef CONFIG_HWMON
|
|
aquantia-objs += aquantia_hwmon.o
|
|
endif
|
|
+ifdef CONFIG_PHYLIB_LEDS
|
|
+aquantia-objs += aquantia_leds.o
|
|
+endif
|
|
obj-$(CONFIG_AQUANTIA_PHY) += aquantia.o
|
|
--- a/drivers/net/phy/aquantia/aquantia.h
|
|
+++ b/drivers/net/phy/aquantia/aquantia.h
|
|
@@ -62,6 +62,26 @@
|
|
#define VEND1_THERMAL_PROV_LOW_TEMP_FAIL 0xc422
|
|
#define VEND1_THERMAL_PROV_HIGH_TEMP_WARN 0xc423
|
|
#define VEND1_THERMAL_PROV_LOW_TEMP_WARN 0xc424
|
|
+
|
|
+#define AQR_NUM_LEDS 3
|
|
+
|
|
+#define VEND1_GLOBAL_LED_PROV 0xc430
|
|
+#define AQR_LED_PROV(x) (VEND1_GLOBAL_LED_PROV + x)
|
|
+#define VEND1_GLOBAL_LED_PROV_ACT_STRETCH GENMASK(0, 1)
|
|
+#define VEND1_GLOBAL_LED_PROV_TX_ACT BIT(2)
|
|
+#define VEND1_GLOBAL_LED_PROV_RX_ACT BIT(3)
|
|
+#define VEND1_GLOBAL_LED_PROV_LINK_MASK (GENMASK(15, 14) | GENMASK(8, 5))
|
|
+#define VEND1_GLOBAL_LED_PROV_LINK100 BIT(5)
|
|
+#define VEND1_GLOBAL_LED_PROV_LINK1000 BIT(6)
|
|
+#define VEND1_GLOBAL_LED_PROV_LINK10000 BIT(7)
|
|
+#define VEND1_GLOBAL_LED_PROV_FORCE_ON BIT(8)
|
|
+#define VEND1_GLOBAL_LED_PROV_LINK2500 BIT(14)
|
|
+#define VEND1_GLOBAL_LED_PROV_LINK5000 BIT(15)
|
|
+
|
|
+#define VEND1_GLOBAL_LED_DRIVE 0xc438
|
|
+#define VEND1_GLOBAL_LED_DRIVE_VDD BIT(1)
|
|
+#define AQR_LED_DRIVE(x) (VEND1_GLOBAL_LED_DRIVE + x)
|
|
+
|
|
#define VEND1_THERMAL_STAT1 0xc820
|
|
#define VEND1_THERMAL_STAT2 0xc821
|
|
#define VEND1_THERMAL_STAT2_VALID BIT(0)
|
|
@@ -115,3 +135,23 @@ static inline int aqr_hwmon_probe(struct
|
|
#endif
|
|
|
|
int aqr_firmware_load(struct phy_device *phydev);
|
|
+
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+int aqr_phy_led_blink_set(struct phy_device *phydev, u8 index,
|
|
+ unsigned long *delay_on,
|
|
+ unsigned long *delay_off);
|
|
+
|
|
+int aqr_phy_led_brightness_set(struct phy_device *phydev,
|
|
+ u8 index, enum led_brightness value);
|
|
+
|
|
+int aqr_phy_led_hw_is_supported(struct phy_device *phydev, u8 index,
|
|
+ unsigned long rules);
|
|
+
|
|
+int aqr_phy_led_hw_control_get(struct phy_device *phydev, u8 index,
|
|
+ unsigned long *rules);
|
|
+
|
|
+int aqr_phy_led_hw_control_set(struct phy_device *phydev, u8 index,
|
|
+ unsigned long rules);
|
|
+
|
|
+int aqr_phy_led_polarity_set(struct phy_device *phydev, int index, unsigned long modes);
|
|
+#endif
|
|
--- /dev/null
|
|
+++ b/drivers/net/phy/aquantia/aquantia_leds.c
|
|
@@ -0,0 +1,140 @@
|
|
+// SPDX-License-Identifier: GPL-2.0
|
|
+/* LED driver for Aquantia PHY
|
|
+ *
|
|
+ * Author: Daniel Golle <daniel@makrotopia.org>
|
|
+ */
|
|
+
|
|
+#include <linux/phy.h>
|
|
+
|
|
+#include "aquantia.h"
|
|
+
|
|
+int aqr_phy_led_brightness_set(struct phy_device *phydev,
|
|
+ u8 index, enum led_brightness value)
|
|
+{
|
|
+ if (index > 2)
|
|
+ return -EINVAL;
|
|
+
|
|
+ return phy_modify_mmd(phydev, MDIO_MMD_VEND1, AQR_LED_PROV(index), VEND1_GLOBAL_LED_PROV_LINK_MASK |
|
|
+ VEND1_GLOBAL_LED_PROV_FORCE_ON |
|
|
+ VEND1_GLOBAL_LED_PROV_RX_ACT |
|
|
+ VEND1_GLOBAL_LED_PROV_TX_ACT,
|
|
+ value ? VEND1_GLOBAL_LED_PROV_FORCE_ON : 0);
|
|
+}
|
|
+
|
|
+static const unsigned long supported_triggers = (BIT(TRIGGER_NETDEV_LINK) |
|
|
+ BIT(TRIGGER_NETDEV_LINK_100) |
|
|
+ BIT(TRIGGER_NETDEV_LINK_1000) |
|
|
+ BIT(TRIGGER_NETDEV_LINK_2500) |
|
|
+ BIT(TRIGGER_NETDEV_LINK_5000) |
|
|
+ BIT(TRIGGER_NETDEV_LINK_10000) |
|
|
+ BIT(TRIGGER_NETDEV_RX) |
|
|
+ BIT(TRIGGER_NETDEV_TX));
|
|
+
|
|
+int aqr_phy_led_hw_is_supported(struct phy_device *phydev, u8 index,
|
|
+ unsigned long rules)
|
|
+{
|
|
+ if (index >= AQR_NUM_LEDS)
|
|
+ return -EINVAL;
|
|
+
|
|
+ /* All combinations of the supported triggers are allowed */
|
|
+ if (rules & ~supported_triggers)
|
|
+ return -EOPNOTSUPP;
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+int aqr_phy_led_hw_control_get(struct phy_device *phydev, u8 index,
|
|
+ unsigned long *rules)
|
|
+{
|
|
+ int val;
|
|
+
|
|
+ if (index >= AQR_NUM_LEDS)
|
|
+ return -EINVAL;
|
|
+
|
|
+ val = phy_read_mmd(phydev, MDIO_MMD_VEND1, AQR_LED_PROV(index));
|
|
+ if (val < 0)
|
|
+ return val;
|
|
+
|
|
+ *rules = 0;
|
|
+ if (val & VEND1_GLOBAL_LED_PROV_LINK100)
|
|
+ *rules |= BIT(TRIGGER_NETDEV_LINK_100);
|
|
+
|
|
+ if (val & VEND1_GLOBAL_LED_PROV_LINK1000)
|
|
+ *rules |= BIT(TRIGGER_NETDEV_LINK_1000);
|
|
+
|
|
+ if (val & VEND1_GLOBAL_LED_PROV_LINK2500)
|
|
+ *rules |= BIT(TRIGGER_NETDEV_LINK_2500);
|
|
+
|
|
+ if (val & VEND1_GLOBAL_LED_PROV_LINK5000)
|
|
+ *rules |= BIT(TRIGGER_NETDEV_LINK_5000);
|
|
+
|
|
+ if (val & VEND1_GLOBAL_LED_PROV_LINK10000)
|
|
+ *rules |= BIT(TRIGGER_NETDEV_LINK_10000);
|
|
+
|
|
+ if (val & VEND1_GLOBAL_LED_PROV_RX_ACT)
|
|
+ *rules |= BIT(TRIGGER_NETDEV_RX);
|
|
+
|
|
+ if (val & VEND1_GLOBAL_LED_PROV_TX_ACT)
|
|
+ *rules |= BIT(TRIGGER_NETDEV_TX);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+int aqr_phy_led_hw_control_set(struct phy_device *phydev, u8 index,
|
|
+ unsigned long rules)
|
|
+{
|
|
+ u16 val = 0;
|
|
+
|
|
+ if (index >= AQR_NUM_LEDS)
|
|
+ return -EINVAL;
|
|
+
|
|
+ if (rules & (BIT(TRIGGER_NETDEV_LINK_100) | BIT(TRIGGER_NETDEV_LINK)))
|
|
+ val |= VEND1_GLOBAL_LED_PROV_LINK100;
|
|
+
|
|
+ if (rules & (BIT(TRIGGER_NETDEV_LINK_1000) | BIT(TRIGGER_NETDEV_LINK)))
|
|
+ val |= VEND1_GLOBAL_LED_PROV_LINK1000;
|
|
+
|
|
+ if (rules & (BIT(TRIGGER_NETDEV_LINK_2500) | BIT(TRIGGER_NETDEV_LINK)))
|
|
+ val |= VEND1_GLOBAL_LED_PROV_LINK2500;
|
|
+
|
|
+ if (rules & (BIT(TRIGGER_NETDEV_LINK_5000) | BIT(TRIGGER_NETDEV_LINK)))
|
|
+ val |= VEND1_GLOBAL_LED_PROV_LINK5000;
|
|
+
|
|
+ if (rules & (BIT(TRIGGER_NETDEV_LINK_10000) | BIT(TRIGGER_NETDEV_LINK)))
|
|
+ val |= VEND1_GLOBAL_LED_PROV_LINK10000;
|
|
+
|
|
+ if (rules & BIT(TRIGGER_NETDEV_RX))
|
|
+ val |= VEND1_GLOBAL_LED_PROV_RX_ACT;
|
|
+
|
|
+ if (rules & BIT(TRIGGER_NETDEV_TX))
|
|
+ val |= VEND1_GLOBAL_LED_PROV_TX_ACT;
|
|
+
|
|
+ return phy_modify_mmd(phydev, MDIO_MMD_VEND1, AQR_LED_PROV(index),
|
|
+ VEND1_GLOBAL_LED_PROV_LINK_MASK |
|
|
+ VEND1_GLOBAL_LED_PROV_FORCE_ON |
|
|
+ VEND1_GLOBAL_LED_PROV_RX_ACT |
|
|
+ VEND1_GLOBAL_LED_PROV_TX_ACT, val);
|
|
+}
|
|
+
|
|
+int aqr_phy_led_polarity_set(struct phy_device *phydev, int index, unsigned long modes)
|
|
+{
|
|
+ bool active_low = false;
|
|
+ u32 mode;
|
|
+
|
|
+ if (index >= AQR_NUM_LEDS)
|
|
+ return -EINVAL;
|
|
+
|
|
+ for_each_set_bit(mode, &modes, __PHY_LED_MODES_NUM) {
|
|
+ switch (mode) {
|
|
+ case PHY_LED_ACTIVE_LOW:
|
|
+ active_low = true;
|
|
+ break;
|
|
+ default:
|
|
+ return -EINVAL;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ return phy_modify_mmd(phydev, MDIO_MMD_VEND1, AQR_LED_DRIVE(index),
|
|
+ VEND1_GLOBAL_LED_DRIVE_VDD,
|
|
+ active_low ? VEND1_GLOBAL_LED_DRIVE_VDD : 0);
|
|
+}
|
|
--- a/drivers/net/phy/aquantia/aquantia_main.c
|
|
+++ b/drivers/net/phy/aquantia/aquantia_main.c
|
|
@@ -740,6 +740,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
{
|
|
PHY_ID_MATCH_MODEL(PHY_ID_AQCS109),
|
|
@@ -759,6 +766,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
{
|
|
PHY_ID_MATCH_MODEL(PHY_ID_AQR111),
|
|
@@ -778,6 +792,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
{
|
|
PHY_ID_MATCH_MODEL(PHY_ID_AQR111B0),
|
|
@@ -797,6 +818,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
{
|
|
PHY_ID_MATCH_MODEL(PHY_ID_AQR405),
|
|
@@ -823,6 +851,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
{
|
|
PHY_ID_MATCH_MODEL(PHY_ID_AQR412),
|
|
@@ -841,6 +876,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
{
|
|
PHY_ID_MATCH_MODEL(PHY_ID_AQR113),
|
|
@@ -860,6 +902,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
{
|
|
PHY_ID_MATCH_MODEL(PHY_ID_AQR113C),
|
|
@@ -879,6 +928,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
{
|
|
PHY_ID_MATCH_MODEL(PHY_ID_AQR114C),
|
|
@@ -898,6 +954,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
{
|
|
PHY_ID_MATCH_MODEL(PHY_ID_AQR813),
|
|
@@ -917,6 +980,13 @@ static struct phy_driver aqr_driver[] =
|
|
.get_strings = aqr107_get_strings,
|
|
.get_stats = aqr107_get_stats,
|
|
.link_change_notify = aqr107_link_change_notify,
|
|
+#if IS_ENABLED(CONFIG_PHYLIB_LEDS)
|
|
+ .led_brightness_set = aqr_phy_led_brightness_set,
|
|
+ .led_hw_is_supported = aqr_phy_led_hw_is_supported,
|
|
+ .led_hw_control_set = aqr_phy_led_hw_control_set,
|
|
+ .led_hw_control_get = aqr_phy_led_hw_control_get,
|
|
+ .led_polarity_set = aqr_phy_led_polarity_set,
|
|
+#endif
|
|
},
|
|
};
|
|
|