mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 14:37:57 +00:00
51a7184a7d
Fixes a build error seen when applying the kernel patches.
Applying patch generic/435-mtd-add-routerbootpart-parser-config.patch
patching file drivers/mtd/parsers/Kconfig
Hunk #1 FAILED at 160.
1 out of 1 hunk FAILED -- rejects in file drivers/mtd/parsers/Kconfig
patching file drivers/mtd/parsers/Makefile
Hunk #1 FAILED at 10.
1 out of 1 hunk FAILED -- rejects in file drivers/mtd/parsers/Makefile
This was missed as 5.4 is currently set as testing kernel
while the main kernel being used is 4.19
Fixes: 2976e423dc
("generic: routerboot partition build bits")
Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
41 lines
1.5 KiB
Diff
41 lines
1.5 KiB
Diff
From 4437e01fb6bca63fccdba5d6c44888b0935885c2 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Thibaut=20VAR=C3=88NE?= <hacks@slashdirt.org>
|
|
Date: Tue, 24 Mar 2020 11:45:07 +0100
|
|
Subject: [PATCH] generic: routerboot partition build bits (5.4)
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This patch adds routerbootpart kernel build bits
|
|
|
|
Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
|
|
---
|
|
drivers/mtd/parsers/Kconfig | 9 +++++++++
|
|
drivers/mtd/parsers/Makefile | 1 +
|
|
2 files changed, 10 insertions(+)
|
|
|
|
--- a/drivers/mtd/parsers/Kconfig
|
|
+++ b/drivers/mtd/parsers/Kconfig
|
|
@@ -176,3 +176,12 @@ config MTD_MYLOADER_PARTS
|
|
|
|
You will still need the parsing functions to be called by the driver
|
|
for your particular device. It won't happen automatically.
|
|
+
|
|
+config MTD_ROUTERBOOT_PARTS
|
|
+ tristate "RouterBoot flash partition parser"
|
|
+ depends on MTD && OF
|
|
+ help
|
|
+ MikroTik RouterBoot is implemented as a multi segment system on the
|
|
+ flash, some of which are fixed and some of which are located at
|
|
+ variable offsets. This parser handles both cases via properly
|
|
+ formatted DTS.
|
|
--- a/drivers/mtd/parsers/Makefile
|
|
+++ b/drivers/mtd/parsers/Makefile
|
|
@@ -9,4 +9,5 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
|
|
obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
-obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
+obj-$(CONFIG_MTD_ROUTERBOOT_PARTS) += routerbootpart.o
|