mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
4234d5ec45
Release notes: https://cmake.org/cmake/help/latest/release/3.31.html Refresh patches: - 120-curl-fix-libressl-linking.patch - 130-bootstrap_parallel_make_flag.patch - 150-zstd-libarchive.patch - 160-disable_xcode_generator.patch Signed-off-by: Jack Sun <sunjiazheng321521@gmail.com> Link: https://github.com/openwrt/openwrt/pull/17056 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
12 lines
410 B
Diff
12 lines
410 B
Diff
--- a/Utilities/cmlibarchive/CMakeLists.txt
|
|
+++ b/Utilities/cmlibarchive/CMakeLists.txt
|
|
@@ -680,7 +680,7 @@ IF(ENABLE_ZSTD)
|
|
SET(ZSTD_FIND_QUIETLY TRUE)
|
|
ENDIF (ZSTD_INCLUDE_DIR)
|
|
|
|
- IF(0) # CMake does not let pkg-config override its search paths.
|
|
+ IF(1) # CMake does not let pkg-config override its search paths.
|
|
IF(UNIX)
|
|
FIND_PACKAGE(PkgConfig QUIET)
|
|
PKG_SEARCH_MODULE(PC_ZSTD libzstd)
|